aggeeva
?>

Решите и составьте программу на языке паскаль. в равнобедренной трапеции стороны а и b, угол при основании равен 60 градусов. найдите площадь, периметр.

Информатика

Ответы

Альберт Луиза1595

таблицы с условия в приложении(14 таблиц).

решение:

а) тип входных данных – числовой.

правило: число х умножают на 2 и прибавляют 1.

б) тип входных данных – числовой.

правило: число f – сумма цифр числа x

в) тип входных данных – числовой.

правило: число х умножают на 2.

г) тип входных данных – числовой.

правило: число х делим на 2 и отбрасываем остаток.

д) тип входных данных – числовой.

правило: остаток от деления х на 2.

е) тип входных данных – числовой.

правило: f – кол-во цифр в числе х.

ж) тип входных данных – числовой.

правило: f – первая буква слова, которое обозначает кол-во цифр в x.

з) тип входных данных – символьный и числовой.

правило: f – это кол-во букв в строке х.

и) тип входных данных – только буквы(символьный).

правило: f – последняя произносимая буква в слове х.

к) тип входных данных – символьный.

правило: каждая буква стоящая на нечетной позиции строки х.

л) тип входных данных – символьный.

правило: f – записанная задом на перёд строка х.

м) тип входных данных – символьный(только кириллица).

правило: первая гласная буква в строке x.

н) тип входных данных – символьный(только кириллица).

правило: последняя согласная буква в строке x.

о) тип входных данных – символьный(только кириллица).

правило: чередование букв по одной с конца и начала.

ka-shop
1. const n = 10; var i,s: integer; m: array [1..n] of integer; begin        randomize;   s: =0;           for i: =1 to n do begin          m[i]: = random(201)-100;           writeln(m[i]);         end;         for i: =1 to n do          if m[i] mod 2 = 0 then          s: =s+m[i];         writeln('summa = ',s);           readln; end. 2. const n = 100; var i,p: integer; b: array [1..n] of integer; begin        randomize;   p: =0;         for i: =1 to n do begin        b[i]: = random(201)-100;           writeln(b[i]);         end;         for i: =1 to n do          if b[i] mod 3 = 0 then          p: =p*b[i];         writeln('proiz = ',p);           readln; end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решите и составьте программу на языке паскаль. в равнобедренной трапеции стороны а и b, угол при основании равен 60 градусов. найдите площадь, периметр.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Avetisyan575
agaltsova86
Бунеева
Karmelita1978
хуйдрочил_Анастасия
Anatolevich_Kulikov1229
marinarodina90
Vrezh
moskvichkabakery56
abdulhakovalily22
juliaipatova1739
Дмитриевич Бирковская69
игнатова_Сергей1228
annakorolkova79
varvara-kulkova