Михайлович_гергиевич315
?>

Напишите программу на pascal'e. вывести на экран число e (основание натурального логарифма) с точностью до десятых. заранее : 3

Информатика

Ответы

rs90603607904
Ответ записать в формате writeln(e: 4: 1). тогда после запятой будет 1 символ
Вайнер

#include <iostream>

using namespace std;

int main()

{

   int min = 20000;

   int count = 0;

   for (int i = 7525; i <= 13486; i++)

   {

       if (i % 7 == 0)

       {

           if (i % 6 != 0)

           {

               if (i % 9 != 0)

               {

                   if (i % 14 != 0)

                   {

                       if (i % 21 != 0)

                       {

                           count += 1;

                           if (i < min)

                           {

                               min = i;

                           }

                       }

                   }

               }

           }

       }

   }

   cout << count << " " << min;

}

Объяснение:

В конце две переменные выводились без пробела, исправил это.

#include <iostream> // Библиотека ввода - вывода

using namespace std; // Пространство имён

int main()

{

   int min = 20000; // Целочисленная переменная min = 20000

   int count = 0; // Целочисленная переменная count = 0

   for (int i = 7525; i <= 13486; i++) // Идём от 7525 до 13486 с шагом в 1

   {

       if (i % 7 == 0) // Если значение переменной i делится на 7 без остатка

       {

           if (i % 6 != 0) // Если остаток при делении значения переменной i на 6 ≠ 0

           {

               if (i % 9 != 0) // Если остаток при делении значения переменной i на 9 ≠ 0

               {

                   if (i % 14 != 0) // Если остаток при делении значения переменной i на 14 ≠ 0

                   {

                       if (i % 21 != 0) // Если остаток при делении значения переменной i на 21 ≠ 0

                       {

                           count += 1; // К переменной count добавляем единицу

                           if (i < min) // Если значение переменной i < значения переменной min

                           {

                               min = i; // В переменную min записываем значение переменной i

                           }

                       }

                   }

               }

           }

       }

   }

   cout << count << " " << min; // Выводим значения переменных count и min через пробел

}

Сергей_Крутикова114

до перелива 8     0     0

1)                 3     5     0

2)                 3     2       3

3)                 6     2       0

4)                 6     0       2

5)                 1     5     2

6)                 1     4       3 

7)                   4     4       0

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу на pascal'e. вывести на экран число e (основание натурального логарифма) с точностью до десятых. заранее : 3
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Мария591
Ilin1022
alisapavlushina
Владислав893
mdubov59
Bi-1704
v79150101401
mariya
idalbaev
daryagulyaeva
danielianruz
alexseyzyablov
m79857860146895
tretyakovamarina201155
Смирнов_Андрей691