Program summa; var a,x: integer; i,s: integer; begin writeln('введите целое число'); readln( a ); x: =a; s: =0; while ( x< > 0 ) do begin s : = s + (x mod 10); x : = x div 10; end; writeln( 'сумма цифр числа ',a,' = ', s ); end.
Любовь-Волков1205
15.02.2023
Var xl,xr,h,x: real; i: integer; begin write('введите левую и правую границы изменения х, затем шаг: '); read(xl,xr,h); for i: =1 to trunc((xr-xl)/h)+1 do begin x: =xl+(i-1)*h; writeln(x: 0: 4,' ',abs(sin(x))+cos(abs( end end. пример введите левую и правую границы изменения х, затем шаг: 1.2 3 0.18 1.2000 1.2943968404439 1.3800 1.17149436167019 1.5600 1.01073783728823 1.7400 0.817321730886476 1.9200 0.597495822534427 2.1000 0.358363262049017 2.2800 0.107651047653376 2.4600 -0.146539653537401 2.6400 -0.395995275405633 2.8200 -0.632655254626053 3.0000 -0.848872488540578
Спиридонова
15.02.2023
Uses crt; constn = 10; vari,b: integer; mas : array[1..n] of integer; v: array[1..n]of integer; max_num, max_index,g,c: integer; begin writeln('введите элементы массива'); for i: =1 to n do readln(mas[i]); for i : = 2 to n doif mas[i] > max_num then beginmax_index : = i; max_num : = mas[i]; end; writeln('введите элементы массива'); for b: =1 to n do readln(v[b]); for b : = 2 to n doif v[b] > g then beginc : = b; g : = v[b]; end; if g< max_num then writeln('максимальное число в первом массиве ',max_num ,' находится на позиции ',max_index)else writeln ('максимальное число во втором массиве ',g,' находится на позиции ',c); end.
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Написать программу которая находит сумму цифр числа паскаль ( ну или хотя бы идейку подкиньте)