randat887040
?>

Для каждой составить программу в pascal, выводящую значение true, если указанное высказывание является истинным, и false - в противном случае (использовать условный оператор нельзя 10. в заданном натуральном трехзначном числе n имеется чётная цифра. 11. сумма каких-либо двух цифр заданного трёхзначного натурального числа n равна третьей цифре. 12. сумма цифр заданного четырёхзначного числа n превосходит произведение цифр этого же числа на 1. 13. сумма двух последних цифр заданного трёхзначного числа n меньше заданного k, а первая цифра больше 5. , прошу, ! !

Информатика

Ответы

koam20167459
// 10. var   n: integer; begin   read(n);   write((n div 100 mod 2 = 0) or (n mod 10 mod 2 = 0) or (n mod 100 div 10 mod 2 = 0)); end. // 11. var   n: integer;   a,b,c: integer; begin   read(n);   a: =n div 100; b: =n mod 100 div 10; c: =n mod 10;   write((a+b=c)or(a+c=b)or(c+b=a)); end. // 12. var   n: integer;   a,b,c,d: integer; begin   read(n);   a: =n div 1000; b: =n mod 1000 div 10 div 10; c: =n mod 100 div 10; d: =n mod 10;   write(a+b+c+d-1=a*b*c*d); end. // 13. var   n,k: integer;   a,b,c: integer; begin   write('n,k= '); read(n,k);   a: =n div 100; b: =n mod 100 div 10; c: =n mod 10;   write((b+c< k)and(a> 5)); end.
Vladstreletskiy
Решение: разрешающая способность сканера 300 dpi (dot per inch - точек на дюйм) означает, что на отрезке длиной 1 дюйм сканер способен различить 300 точек. переведем разрешающую способность сканера из точек на дюйм (1 дюйм = 2,54 см) в точки на сантиметр: 300dpi : 2,54 ≈ 118 точек/см. следовательно, размер изображения в точках составит 25*118 и 30*118 = 2950х3540 общее количество точек изображения равно: 2950 * 3540 = 10 443 000. информационный объем файла равен: 3 байта= 24 бита. 24 * 10 443 000 = 250632000 бит = 31329000 байт = 30595 кб ≈ 30 мб
buriginast5
Для начала, список некоторых недокументированных параметров. сommand.com - можно запускать и как отдельную, "чистую" сессию из уже запущенного dos-сеанса.  command /z (только windows 95 или osr2)  command.com /z показывает значение "errorlevel".этот параметр позволяет с большим удобством обрабатывать различные события, ситуации и ошибки в процессе выполнения внешних команд дос в bat-файлах. опять таки сommand.com c этим параметром можно запускать и как отдельную сессию из уже запущенного dos-сеанса. 

  fdisk.exe  включает возможность использования файловой системы fat32 на жестких дисках с объемом меньше 512 мегабайт.

fdisk /mbr (ms-dos 6.00 или выше)  восстанавливает поврежденный boot-сектор винчестера просто перезаписывая его (вернее говоря, на диск записывается новая mbr (master boot record) без внесения изменений в конфигурацию разделов диска)

недокументированные параметры format.com  format диск: /z: n (windows 95 osr 2.0 и выше)  эта недокументированная опция позволяет форматировать диски с fat32  файловой системой и с размером кластера равным n раз по 512 байт. то есть  при значении n равном 2, размер кластера будет равняться одному килобайту (2*512=1024).

недокументированные параметры mem.exe  mem /a (ms-dos 6.00 и выше)  внешняя команда дос mem с недокументированным параметром /a показывает стандартную информацию о памяти плюс информацию о сегменте hma (high memory area). hma - это небольшой 64-х килобайтная область памяти выше первого мегабайта, куда обычно загружается ядро дос, а также размещаются дос-буфера. доступом же к hma заведует himem.sys, открывающий так называемую линию a20. 

недокументированные параметры команды ver  ver /r (windows 95 и выше)  эта встроенная дос команда с недокументированным параметром /r позволяет не только вывести версию операционной системы, но и показать в каком сегменте находится дос (обычно hma, если в config.sys прописано dos=high).

недокументированная команда lfnfor  lfnfor [on | off | /? ] (windows 95 и выше)  ну и напоследок просто неизвестная большинству пользователей встроенная команда дос, отсутствующая в описаниях. эта команда позволяет разрешать/запрещать использование длинных имен файлов при обработке команд for, используемых в bat-файлах.

используя команды с параметрами(ввод с клавиатуры через разделитель), вы работаете с каталогами, либо изменяете/вводите атрибуты файлов,либо проверяете диск и читаете отчеты.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Для каждой составить программу в pascal, выводящую значение true, если указанное высказывание является истинным, и false - в противном случае (использовать условный оператор нельзя 10. в заданном натуральном трехзначном числе n имеется чётная цифра. 11. сумма каких-либо двух цифр заданного трёхзначного натурального числа n равна третьей цифре. 12. сумма цифр заданного четырёхзначного числа n превосходит произведение цифр этого же числа на 1. 13. сумма двух последних цифр заданного трёхзначного числа n меньше заданного k, а первая цифра больше 5. , прошу, ! !
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Vyacheslavovna1108
filimon131262
denbelousov963
Andreevich
Nikolaevna382
tgeraskina
sedalex
vsbrelok
lider123
Mikhailovna_Litvinova276
Мартынова_Ринатовна1657
Olga Arutyunyan
sastakhova
хуйдрочил_Анастасия
виталийВячеславович