vis-lyubov8832
?>

Прошу написать программу в паскале) с клавиатуры ввели число. если это число нечетное, то нужно найти сумму чисел в диапазоне от 1 до этого числа, иначе вывести сообщение о том, что число нечетное.

Информатика

Ответы

abakas235
Заметим, что числа образуют арифметическую прогрессию, а её сумма известна: поэтому два варианта программы: один вычисляет сумму накоплением, второй сразу определяет результат по формуле. хороший пример того, что программист должен знать . var   n, i, s: integer; begin   write('введите натуральное число: ');   readln(n);   if (n mod 2) = 0 then   begin       s : = 0;       for i : = 1 to n do s : = s + i;       writeln('сумма чисел от 1 до ', n, ' равна ', s)   end   else writeln('введено нечетное число') end. тестовое решение: введите натуральное число: 8 сумма чисел от 1 до 8 равна 36 var   n, s: integer; begin   write('введите натуральное число: ');   readln(n);   if (n mod 2) = 0 then       writeln('сумма чисел от 1 до ', n, ' равна ', ((1 + n) * n) div 2)   else writeln('введено нечетное число') end. тестовое решение: введите натуральное число: 8 сумма чисел от 1 до 8 равна 36
AverinAA6077
// pascalabc.net 3.2, сборка 1407 от 18.03.2017 // внимание! если программа не работает, обновите версию! function geron(a,b,c: real): real; // возвращает площадь треугольника со сторонами a,b,c begin   var p: =(a+b+c)/2; // полупериметр   result: =sqrt(p*(p-a)*(p-b)*(p-c)) end; function sp(ab,bc,ca,ad,bd,cd: real): real; // возвращает площадь полной поверхности пирамиды begin   result: =geron(ab,bc,ca)+geron(ab,ad,bd)+geron(bc,bd,cd)+           geron(ca,cd,ad) end; procedure vvod(var ab,bc,ca,ad,bd,cd: real); // ввод значений ребер begin   writeln('введите значения ребер пирамиды');   write('ребра основания- ab,bc,ca: '); read(ab,bc,ca);   write('боковые ребра- ad,bd,cd: '); read(ad,bd,cd) end; begin   var ab1,bc1,ca1,ad1,bd1,cd1: real;   vvod(ab1,bc1,ca1,ad1,bd1,cd1);   var sp1: =sp(ab1,bc1,ca1,ad1,bd1,cd1);   var ab2,bc2,ca2,ad2,bd2,cd2: real;   vvod(ab2,bc2,ca2,ad2,bd2,cd2);   var sp2: =sp(ab2,bc2,ca2,ad2,bd2,cd2);   var d: =sp1-sp2;   if d> 0 then writeln('площадь sполн 1й пирамиды больше на ',d)   else       if d< 0 then writeln('площадь sполн 2й пирамиды больше на ',-d)       else writeln('площади sполн пирамид равны'); end.
sychevao19975
Что мы знаем о войне немного  по рассказам бабушек и мам  знаем, что надежда и тревога  об руку ходили по домам  слухи зависали  как знамена  дымом застилался горизонт  многоверстный и многоименный  жаждал крови ненасытный фронт  а из тыла за волной волна  шла латать верховные промашкивсасывала мальчиков война   и выплевывала мертвые бумажкикаждый шаг   к победе ли к бедесводки измеряли расстояньем  даже самый распобедный день  был комуто вечным расставаньемгоды возвращающий экраночевидцев честные романывсе равно останутся обманомссадины не заменяют рантолько изредка за толщей дней  вдруг всплеснёт сирены голос лютыйзамирая криками детей  и застынет сердце на минуту

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Прошу написать программу в паскале) с клавиатуры ввели число. если это число нечетное, то нужно найти сумму чисел в диапазоне от 1 до этого числа, иначе вывести сообщение о том, что число нечетное.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Yekaterina Oksyuta1657
alina-bas
Ильдар-Кугай
Aleksandrovich-Mayatskikh
Анна1417
konnovakat1
denisov4
Зинина-Олесия
ski89439
Serdechnaya636
Ivan500
iralkap
kuziv31
prohorovalena
Наталья Юрьевич1228