Evsevia-a
?>

Написать программу на turbopascal. дано натуpальное n. записать в файл целые числа , где bi=i2-2i+1 при i=1, . найти сумму всех четных чисел в файле.

Информатика

Ответы

alexeytikhonov
Const n=10; m=3; var  a: array[1..n,1..m] of integer; i,j,s,k: integer; p: real; begin randomize; writeln('исходный массив: '); for i: =1 to n do   begin   for j: =1 to m do   begin     a[i,j]: =random(81)+20;     write(a[i,j]: 4);   end;   writeln;   end; s: =0; for i: =1 to n do   for j: =1 to m do s: =s+a[i,j]; p: =s/n*0.8; writeln('p = ',p: 5: 2); writeln('зачислены: '); k: =0; for i: =1 to n do   begin   s: =0;   for j: =1 to m do s: =s+a[i,j];   if s> =p then begin write(i,' '); k: =k+1; end;   end; writeln; writeln('k = ',k); end. пример: 76 62 50 37 73 22 61 99 36 22 69 38 27 82 22 93 56 37 79 84 51 83 31 60 61 39 95 70 70 100 p = 142.80 зачислены: 1 3 6 7 8 9 10   k = 7
gusrva3001
Const   c = 100; var  n, i : integer;   a     : array [1..c] of integer;   flag : boolean; begin   write('n: ');   readln(n);       if (n < 1) or (n > c) then   begin     write('ошибка, недопустимое число.');       exit;   end;     for i : = 1 to n do   begin     write('a[', i,']: = ');     readln(a[i]);   end;       flag : = false;   for i : = 1 to n do     if a[i] < 1 then       begin         flag : = true;       break;       end;     if flag then writeln('нет') else writeln('да');       readln; end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на turbopascal. дано натуpальное n. записать в файл целые числа , где bi=i2-2i+1 при i=1, . найти сумму всех четных чисел в файле.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Матвеев
Valeria123864531
kzhgutova
sokolskiy458
ielienakozlova696
iburejko7
alekbur
Vasileva
TSKaraulova
Vyacheslavovich-Gubanov
nzagrebin363
iriska-669
Negutsa_Kseniya524
veniaminsem
igor8809337
▲