mrvasilev2012
?>

Питон 12 напишите программу, которая сортирует массив по возрастанию "методом камня": аналогично "методу пузырька", но в обратном порядке: самый "тяжелый" элемент из оставшихся спускается к концу массива. входные данные первая строка содержит размер массива n . во второй строке через пробел n чисел – элементы массива. гарантируется, что 0 < n ≤ 10000 . выходные данные программа должна выводить весь массив после каждой перестановки элементов. все элементы массива выводятся в одну строку и разделяются пробелами, после окончания вывода массива выполняется переход на новую строку. если перестановок не было, программа выводит только число 0. примеры входные данные 4 4 3 2 1 выходные данные 3 4 2 1 3 2 4 1 3 2 1 4 2 3 1 4 2 1 3 4 1 2 3 4

Информатика

Ответы

LidiyaBorzikh
Var x,y,d,k: integer; begin for x: = 0 to 15 do       begin       y: =x*x+x+17;       write('f(',x,') = ',y);       k: =0;       d: =y div 2;       while d > 1 do             begin             if y mod d = 0 then k: =k+1;             d: =d-1             end;       if k = 0 then writeln(' - простое')       else writeln(' - составное')       end; end.
Alnkseevna
Var  a: array[1..10, 1..10] of real;   n, m, i, j, i1, j1, i2, j2: byte;   min, max: real; begin  writeln('введите кол-во строк и столбцов');   read(n, m); writeln;   for i : = 1 to n do  begin    writeln('введите ', m, ' эл. ', i, '-й строки матрицы');     for j : = 1 to m do read(a[i, j]) end;   writeln('ваша матрица: ');   for i : = 1 to n do  begin    for j : = 1 to m do write(a[i, j]: 7: 2);     writeln end;   for i : = 1 to n do  begin    min : = a[i, 1]; i1 : = i; j1 : = 1;     for j : = 1 to m do     if a[i, j] < min then begin        min : = a[i, j]; i1 : = i; j1 : = j      end;       if i = 1 then    begin   max : = min; i2 : = i1; j2 : = j1    end    else    if min > max then    begin      max : = min; i2 : = i1; j2 : = j1    end  end;   writeln('максимальным из минимумов строк является элемент ', max: 6: 2, ' с индексами [', i2, ',', j2, ']'); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Питон 12 напишите программу, которая сортирует массив по возрастанию "методом камня": аналогично "методу пузырька", но в обратном порядке: самый "тяжелый" элемент из оставшихся спускается к концу массива. входные данные первая строка содержит размер массива n . во второй строке через пробел n чисел – элементы массива. гарантируется, что 0 < n ≤ 10000 . выходные данные программа должна выводить весь массив после каждой перестановки элементов. все элементы массива выводятся в одну строку и разделяются пробелами, после окончания вывода массива выполняется переход на новую строку. если перестановок не было, программа выводит только число 0. примеры входные данные 4 4 3 2 1 выходные данные 3 4 2 1 3 2 4 1 3 2 1 4 2 3 1 4 2 1 3 4 1 2 3 4
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

gub191025
Natalya1895
bondarenkoss
Андреевич
asskokov
Itina321t
SVETLANAluiza1534
platonm777639
info292
maksteks
petrowanastya202081
Гарик383
Мария Кашихина
Anatolevna
a8227775
▲