Составить программу в паскале, позволяющую получить словесное описание школьных отметок: 1-плохо 2-не удовлетворительно 3-удовлетворительно 4-хорошо 5-отлично
begin write('оценка: '); readln(mark); case mark of 1: writeln ('плохо'); 2: writeln ('не удовлетворительно'); 3: writeln ('удовлетворительно'); 4: writeln ('хорошо'); 5: writeln ('отлично! '); end; readln; end.
konstantin0112
03.03.2022
Так как информации о том, каким образом должен выплачиваться кредит, нет, то для расчета взят вариант аннуитетного платежа. результаты расчетов показаны в прилагаемом файле. формулы для такого варианта: для ячеек b6-b9: =$b$2*($c$2+$c$2/(степень((1+$c$2); $d$2)-1)) в ячейке d6: =e5*$c$2 (формулы в d7-d9 получаются копированием) в ячейке c6: =b6-d6 (формулы в c7-c9 получаются копированием) в ячейке e6: =e5-c6 (формулы в e7-e9 получаются копированием)
sabinina0578
03.03.2022
Во вложении блок-схема алгоритма. в ней считается, что массив х(10) уже имеется, поскольку в условии не сказано, как именно этот массив формируется. const n=10; var x: array[1..n] of integer; i,k: integer; begin { подготовка исходного массива } randomize; writeln('исходный массив'); for i: =1 to n do begin x[i]: =random(200)-100; write(x[i],' ') end; writeln; { непосредственно алгоритм } k: =0; i: =1; while (i< =n) and (k=0) do if x[i]< 0 then for k: =i to n-1 do x[k]: =x[k+1] else inc(i); for i: =1 to n-1 do write(x[i],' ') end. контрольное решение исходный массив 93 59 61 -76 30 -79 52 -76 91 -82 93 59 61 30 -79 52 -76 91 -82
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Составить программу в паскале, позволяющую получить словесное описание школьных отметок: 1-плохо 2-не удовлетворительно 3-удовлетворительно 4-хорошо 5-отлично
var mark: integer;
begin write('оценка: '); readln(mark); case mark of 1: writeln ('плохо'); 2: writeln ('не удовлетворительно'); 3: writeln ('удовлетворительно'); 4: writeln ('хорошо'); 5: writeln ('отлично! '); end; readln; end.