sherifovaelina
?>

Здраствуйте)прошу нужно решить , расписав её для паскаля, прошу ! вот сама - дан массив из n элементов.написать программу, уменьшающую все элементы массива на единицу.

Информатика

Ответы

Газинурович
Program sss; var i,n,k: integer; a: array[1..100]of integer; for i: =1 to n do begin read(k); a[i] : = k - 1; write(a[i],' '); end; end.
leonidbaryshev19623

операционная система windows

windows  — семейство проприетарных операционных систем корпорации microsoft, ориентированных на применение графического интерфейса при .

по состоянию на декабрь 2012 года под операционных систем семейства windows по данным ресурса netmarketshare (net applications) работает около 92 % персональных компьютеров.

операционные системы windows работают на платформах x86, x86-64, ia-64, arm.

windows как расширение для dos

первые версии windows не были полноценными операционными системами, а являлись надстройками к операционной системе ms-dos и были по сути многофункциональным расширением, добавляя поддержку новых режимов работы процессора, поддержку , обеспечивая стандартизацию интерфейсов аппаратного обеспечения и единообразие для пользовательских интерфейсов программ. предоставляли встроенные средства (gdi и user, первые версии windows вообще состояли из трех модулей — kernel, gdi и user, первый из них предоставлял вызовы памятью, запуском .exe-файлов и загрузкой .dll-файлов, второй — графику, третий — окна) для создания графического интерфейса пользователя. они работали с процессорами начиная с intel 8086.

windows 1.0 (1985)

windows 2.0 (1987)

windows 2.1 (windows 386, 1987) — в системе появилась возможность запуска dos-приложений в графических окнах.

windows 3.0 (1990) — улучшена поддержка защищённого режима работы процессора.

windows 3.1 (1992) — серьёзно переработанная windows 3.0; добавлен механизм ole, печать в режиме wysiwyg («что видите, то и получите»), шрифты truetype, изменён проводник (диспетчер файлов), добавлены мультимедийные функции.

windows для рабочих групп (windows for workgroups, wfwg) 3.1/3.11 — первая версия ос семейства с поддержкой локальных сетей. в wfwg 3.11 также испытывались отдельные усовершенствования ядра, применённые позднее в windows 95.

семейство windows 9x

включает в себя windows 95, windows 98 и windows me.

windows 95 была выпущена в 1995 году. её отличительными особенностями являются: новый пользовательский интерфейс, поддержка длинных имён файлов, автоматическое определение и конфигурация периферийных устройств plug and play, способность исполнять 32-битные приложения и наличие поддержки tcp/ip прямо в системе. windows 95 использует вытесняющую и выполняет каждое 32-битное приложение в своём адресном пространстве.

семейство windows nt

все операционные системы этого семейства являются полностью 32- или 64- битными операционными системами, и не в ms-dos даже для загрузки.

windows nt 3.1 (1993)

windows nt 3.5 (1994)

windows nt 3.51 (1995)

windows nt 4.0 (1996)

windows 2000 (2000) — windows nt 5.0

windows xp (2001) — windows nt 5.1

windows xp 64-bit edition (2003) — windows nt 5.2

windows server 2003 (2003) — windows nt 5.2

windows vista (2006) — windows nt 6.0

windows home server (2007) — windows nt 5.2

windows server 2008 (2008) — windows nt 6.0

windows small business server (2008) — windows nt 6.0

windows 7 — windows nt 6.1 (2009)

windows server 2008 r2 — windows nt 6.1 (2009)

windows home server 2011 — windows nt 6.1 (2011)

windows 8 — windows nt 6.2 (2012)

windows server 2012 — windows nt 6.2 (2012)

в основу семейства windows nt положено разделение адресных пространств между процессами. каждый процесс имеет возможность работать с выделенной ему памятью. однако он не имеет прав для записи в память других процессов, драйверов и системного кода.

семейство windows nt относится к операционным системам с вытесняющей . разделение процессорного времени между потоками происходит по принципу «карусели». ядро операционной системы выделяет квант времени (в windows 2000 квант равен примерно 20 мс) каждому из потоков по очереди при условии, что все потоки имеют одинаковый приоритет. поток может отказаться от выделенного ему кванта времени. в этом случае система перехватывает у него (даже если выделенный квант времени не закончен) и передаёт другому потоку. при передаче другому потоку система сохраняет состояние всех регистров процессора в особой структуре в оперативной памяти. эта структура называется контекстом потока. сохранение контекста потока достаточно для последующего возобновления его работы.

семейство windows для карманных компьютеров

это семейство операционных систем реального времени было специально разработано для мобильных устройств. поддерживаются процессоры arm, mips, superh и x86. в отличие от остальных операционных систем windows, операционные системы этого семейства только в составе готовых устройств, таких как смартфоны, карманные компьютеры, gps-навигаторы, mp3-проигрыватели и другие.

windows ce

windows mobile

windows phone

семейство встраиваемых ос windows embedded

windows embedded — это семейство операционных систем реального времени, было специально разработано для применения в различных встраиваемых системах. ядро системы имеет общее с семейством ос windows ce и поддерживает процессоры arm, mips, superh и x86.

elena-ruzadom

ответ:

#include

#include  

using namespace std;

 

struct sponsor

{

char name[32];

char surname[32];

double sum;

};

 

sponsor* addstruct(sponsor* obj, const int amount);

void setdata(sponsor* obj, const int amount);

void showdata(const sponsor* obj, const int amount);

 

int main()

{

setlocale(lc_all, "rus");

 

sponsor* oursponsors = 0;

int sponsoramount = 0;

int yesornot = 0; //   продолжить или остановить ввод данных

 

do

{

oursponsors = addstruct(oursponsors, sponsoramount);

setdata(oursponsors, sponsoramount);

 

sponsoramount++;

 

cout < < "продолжить ввод данных (1 - да, 0 - нет): ";

cin > > yesornot;

cin.get();

} while (yesornot ! = 0);

 

showdata(oursponsors, sponsoramount);

 

delete[] oursponsors;

return 0;

}

 

sponsor* addstruct(sponsor* obj, const int amount)

{

if (amount == 0)

{  

obj = new sponsor[amount + 1]; // выделение памяти для первой структуры

}

else

{

sponsor* tempobj = new sponsor[amount + 1];

 

for (int i = 0; i < amount; i++)

{

tempobj[i] = obj[i]; // копируем во временный объект

}

delete [] obj;

 

obj = tempobj;  

}  

return obj;

}

//~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

void setdata(sponsor* obj, const int amount)

{

cout < < "фамилия: ";

cin.getline(obj[amount].surname, 32);

cout < < "имя: ";

cin.getline(obj[amount].name, 32);

cout < < "сумма пожертвования: ";

cin > > obj[amount].sum;

cin.get();  

cout < < endl;  

}

//~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

void showdata(const sponsor* obj, const int amount)

{

system("cls");

cout < < "№   " < < "фамилия\t" < < "имя\t" < < "сумма\t" < < endl;

cout < < "========================================" < < endl;

for (int i = 0; i < amount; i++)

{  

cout < < i + 1 < < "   " < < obj[i].surname < < '\t' < < obj[i].name < < '\t' < < obj[i].sum < < endl;

}

}

объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Здраствуйте)прошу нужно решить , расписав её для паскаля, прошу ! вот сама - дан массив из n элементов.написать программу, уменьшающую все элементы массива на единицу.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

stasletter
mdubov59
aquilonis
delta88
IP1379
sandovo590
akakne86
shturman-765255
iplizogub74
Zeitlinama7067
Буянто1346
juliaWinter
hrviko
ivanova229
qwe54344