grebish2002
?>

Составьте быстро! 1)составьте программу вычесления суммы s=1+2^2+3^3+4^4++n^n. 2)даны годовые оценки учеников класса по .верно ли , что количесвто пятерок больше, чем двоек? 3)известна высота двадцати зданий.найти минимальную высоту. 4известна высота двадцати зданий.найти два максимальный значения

Информатика

Ответы

len4ik1986
Var p, q: longint;   n, i, j, c: integer; begin    // 1   write('n='); readln(n);   for i : = 1 to n do begin     q : = 1;     for j : = 1 to i do q : = q * i;     p : = p + q;   end;   writeln ('значение = ', p);       // 2   write('число годовых оценок='); readln(n);   p: =0;   for i : = 1 to n do begin     write('оценка: '); readln(c);     if c = 5 then p : = p + 1     else if c = 2 then p : = - 1;   end;   writeln(p > 0);       // 3   n : = 20; p : = maxint;   for i : = 1 to n do begin     write('введите высоту здания ', i, ': ');     readln(c);     if c < p then p : = c;   end;   writeln('минимальная высота: ', p);       //4   n : = 20; p : = -1;   for i : = 1 to n do begin     write('введите высоту здания ', i, ': ');     readln(c);     if c > p then p : = c;   end;   writeln('максимальное значение высоты: ', p); end.
Valerevna
1) var sum, number, n: integer; begin   sum : = 0;   number : = 1;   write('введите n: ');   readln(n);   while (number < = n) do   begin     sum : = sum + number;     number : = number + 2;   end;   write('сумма равна ', sum); end. 2) var prod, number, n: integer; begin   prod: = 1;   number : = 3;   write('введите n:   ');   readln(n);   while (number < = n) do   begin     prod : = prod *  number;     number : = number + 3;   end;   write('произведение равно  ', prod); end. 3) var number, n: integer; begin   number : = 1;   write('введите n:   ');   readln(n);   writeln('таблица: ');   while (number < = n) do   begin     writeln(number: 5, number*number: 5, number*number*number: 5);     number : = number + 1;   end; end.
eisakov86

у вас дано несколько чисел введённых с клавиаатуры или генерацией(random)вы проверяете 1)трёхзначность (a> 99) and (a< 1000)

                                                          2)оканчивается ли трёхзначное число тройкой (a mod 10=3)

if (a> 99) and (a< 1000) and (a mod 10=3)

 

естественно проверка делается в цикле.

 

нужно было указать в условии как вводятся числа (a), сколько их

или числа вводятся в массив

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте быстро! 1)составьте программу вычесления суммы s=1+2^2+3^3+4^4++n^n. 2)даны годовые оценки учеников класса по .верно ли , что количесвто пятерок больше, чем двоек? 3)известна высота двадцати зданий.найти минимальную высоту. 4известна высота двадцати зданий.найти два максимальный значения
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ksankaaleks611
eisakov86
pechinin
magichands68
georgegradoff122
krutikovas
Aleksey19801
Vasilisan
tinadarsi
smartschoolfili6
rsd737
antongenfon
VladimirovnaKashintsev1151
intermar2000
Kalashnikova