anytkaakk
?>

Натуральные числа а и в являются числителем и знаменателем обыкновенной дроби. сократить эту дробь, написать программу на си

Информатика

Ответы

vikabobkova2010
#include< iostream> #include< windows.h> #include< locale> int main() {     setlocale(lc_all, "russian");     int a, b;     int   n;     std: : cout < < "введите числитель: ";     std: : cin > > a;     std: : cout < < "введите знаменатель: ";     std: : cin > > b;     n = a < b ? a: b;     for(int i=1; i< =n; i++)       %i) & & ! (b%i))        {          a/=i;           b/=i;         }     std: : cout < < " " < < a < < " \n" < < "";     if(b == 1)  std: : cout < < " = " < < a;     std: : cout < < "\n " < < b < < " \n";       system("pause");     return 0; }
pwd10123869
Var   i,n,h,m,d,r: integer; begin   write('количество детей: '); read(n);   write('высота забора: '); read(h);   writeln('вводите через пробел рост детей (мальчиков - с минусом');   m: =0; d: =0;   for i: =1 to n do   begin       read(r);       if (r< 0) and (-r> h) then inc(m)       else           if r+10> h then inc(d)   end;   writeln('видно мальчиков- ',m,', девочек- ',d) end.   контрольное решение количество детей: 8 высота забора: 112 вводите через пробел рост детей (мальчиков - с минусом -119 -124 118 107 -115 113 -111 105 видно мальчиков- 3, девочек- 4
antilopa001
Формула несколько не совсем понятна, но если что функцию не трудно переделать var       x: real; function z(x: real): real; begin       if x > = 1 then               z : = ln(x)       else               z : = 1; end; begin       x : = 1;       writeln('z(', x, ') = ', z(x));             x : = -1;       writeln('z(', x, ') = ', z(x));             write('x=');       readln(x);       writeln('z(', x, ') = ', z(1)); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Натуральные числа а и в являются числителем и знаменателем обыкновенной дроби. сократить эту дробь, написать программу на си
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Лилия-Карпухина337
orion-inginiring7807
anastasiavilina
evageniy79
strelnikov-aa
atamanov5
Матвеев
Горностаева831
Svetlana395
Yurevich1243
Olybetezina1973
Yurevich1701
djevgen
Александровна-Павловна
alexeylipatov