Гаевая1290
?>

Написать программу в паскале! задано 2n целых чисел. требуется разбить их на пары, так, чтобы сумма произведений чисел в парах была как можно больше. например, если заданы числа 1, 2, 3 и 4, то оптимальный способ разбиения на пары -(1, 2) и (3, 4 в этом случае искомая сумма равна 14. требуется написать программу, которая по заданному числу n (1 меньше или ровно n и n меньше или ровно 100) и набору из 2n чисел выдаст их оптимальное рабиение на пары.

Информатика

Ответы

pak1998378
Var   n,i,j,c: integer;   mas: array[1..999] of integer; begin   readln(n);   for i: =1 to 2*n do   readln(mas[i]);   //группируем массив в порядке возрастания   for i : = 1 to  2*n-1 do     for j : = 1 to  2*n-i do       if mas[j] > mas[j+1] then     begin      c  : =  mas[j];       mas[j] : =  mas[j+1];       mas[j+1] : =  c;     end;   writeln('оптимальные пары: ');   for i: =1 to 2*n do  begin  if i mod 2 = 1 then    write(mas[i],' и  ');   if i mod 2 = 0 then    writeln(mas[i]);   end; end.
BogdanR106203
Операционная система (ос) – это комплекс взаимосвязанных системных программ для организации взаимодействия пользователя с компьютером и выполнения всех других программ. ос относятся к составу системного программного обеспечения и являются основной его частью. операционные системы: ms dos 7.0, windows vista business, windows 2008 server, os/2, unix, linux. основные функции ос: устройствами компьютера (ресурсами), т.е. согласованная работа всех аппаратных средств пк: стандартизованный доступ к периферийным устройствам, оперативной памятью и др. процессами, т.е. выполнение программ и их взаимодействие с устройствами компьютера. доступом к данным на энергонезависимых носителях (таких как жесткий диск, компакт-диск и т. как правило, с файловой системы. ведение файловой структуры. пользовательский интерфейс, т.е. диалог с пользователем.
annanechaeva567
Нужно воспользоваться следующими формулами: 2^i=n, v=k*i, где i-количество бит, отводимых на один цвет (глубина цвета), n-количество цветов, v- информационный объем рисунка (файла),k- количество пикселей (расширение экрана). 1)k=320*400=128000; v=125кб=125*1024*8бит=1024000бит; i=v/k=8; n=2^8=256; ответ: 256 цветов. 2)k=256*512=131072; n=16; v-? ; 2^i=16; i=4; v=i*k=524288бит=65536байт; ответ: 65536байт. 3)n=256; v=1кб=1024байта=8192бита; k-? ; 2^i=256 i=8; k=v/i=1024бита=128байт; ответ: 128байт.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в паскале! задано 2n целых чисел. требуется разбить их на пары, так, чтобы сумма произведений чисел в парах была как можно больше. например, если заданы числа 1, 2, 3 и 4, то оптимальный способ разбиения на пары -(1, 2) и (3, 4 в этом случае искомая сумма равна 14. требуется написать программу, которая по заданному числу n (1 меньше или ровно n и n меньше или ровно 100) и набору из 2n чисел выдаст их оптимальное рабиение на пары.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

okunevo2010
matoksana
kruttorg
horina12
Оксана170
Александра Викторович531
toxicfish
turoverova5
Ruzalina_Svetlana1435
Galinagol559
Nadirovich1317
pelagia-kola2658
Konchenko1980
uttgroup
horina12