zdanovich90764
?>

:написать программу на паскале, с (с++) или бейсике. входной файл: input.txt. выходной файл: output.txt. ограничение времени выполнения программы: 1 секунда на тест. спецификация входа: в первой строке входного файла записано целое число n (1 n 1000), во второй строке файла записаны целые числа x1, x2, xn, (-109 xi 109 спецификация выхода: запишите в выходной файл числа xi в порядке неубывания. пример входа: 5 12 10 5 10 7 пример выхода: 5 7 10 10 12

Информатика

Ответы

yakushkinayuliya

program exs; var a : array [1..1000] of integer; n, i : integer;

procedure qsort(l, r: integer); var i, j, key, buf : integer; begin i : = l; j: = r; key: =a[(l+r) div 2]; repeat while a[i] < key do inc(i); while a[j] > key do dec(j); if i< =j then begin buf: =a[i]; a[i]: =a[j]; a[j]: =buf; inc(i); dec(j); end; until (i> j); if (l < j) then qsort(l, j); if (i < r) then qsort(i, r); end;

begin readln(n); for i: = 1 to n do begin read(a[i]); end; qsort(1, n); for i: =1 to n do begin write(a[i], ' '); end; end.

whitewhit90
Пишу частями, пробелы восполни сам type       massiv = array [1..1000] of integer; var       i,n,summa : integer;       srednee : real;       a : massiv; write('введите кол-во элементов : '); readln(n);   summa : = 0; // начальное значение for i: =1 to n do         begin                 write('введите ',i, ' элемент: '); readln(a[i]);                 summa : = summa + a[i];         end;
ruslanriad10
Const   n = 5; type   tm = array[1..n, 1..n] of integer;   tv = array[1..n] of integer; procedure prodmv(a: tm; b: tv; var c: tv); var   i, j, s: integer; begin   for i : = 1 to n do   begin       s : = 0;       for j : = 1 to n do s : = s + a[i, j] * b[j];       c[i] : = s;   end end; procedure sumv(a, b: tv; var c: tv); var   i: integer; begin   for i : = 1 to n do c[i] : = a[i] + b[i] end; procedure initmatrix(var a: tm; p, q: integer); { инициализация элементов случайными числами на [p; q]} var   i, j, k: integer; begin   k : = q - p + 1;   for i : = 1 to n do       for j : = 1 to n do           a[i, j] : = random(k) + p end; procedure initvector(var a: tv; p, q: integer); { инициализация элементов случайными числами на [p; q]} var   i, k: integer; begin   k : = q - p + 1;   for i : = 1 to n do       a[i] : = random(k) + p end; procedure displaymatrix(a: tm; s: string); var   i, j: integer; begin   writeln(s);   for i : = 1 to n do   begin       for j : = 1 to n do write(a[i, j]: 5);       writeln   end end; procedure displayvector(a: tv; s: string); var   i: integer; begin   writeln(s);   for i : = 1 to n do write(a[i]: 5);   writeln end; var   a, b: tm;   x, y, r, r1, r2: tv; begin   randomize;   initmatrix(a, -50, 50);   displaymatrix(a, 'матрица а');   initmatrix(b, -20, 65);   displaymatrix(b, 'матрица b');   initvector(x, -10, 14);   displayvector(x, 'вектор x');   initvector(y, 5, 40);   displayvector(y, 'вектор y');   prodmv(a, x, r1);   prodmv(b, y, r2);       { для отладки раскомментарить две нижележащие строчки }   { displayvector(r1,'вектор r1');       displayvector(r2,'вектор r2'); }   sumv(r1, r2, r);   displayvector(r, 'вектор результата') end. тестовое решение: матрица а   -19    27    30    25  -14     32  -35      9  -38    16   -39  -36    13    41  -37       7  -18    -8    35  -10       1  -48      1  -19    -2 матрица b   -15    62  -18    58    62     32    58    43      3    12     15    11    39  -20  -16     47  -10    24    16    55     -8    46    10      0    45 вектор x       2    -6    10      0    -3 вектор y     15    14    22    14    15 вектор результата   2131 2776 1096 2214 1725

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

:написать программу на паскале, с (с++) или бейсике. входной файл: input.txt. выходной файл: output.txt. ограничение времени выполнения программы: 1 секунда на тест. спецификация входа: в первой строке входного файла записано целое число n (1 n 1000), во второй строке файла записаны целые числа x1, x2, xn, (-109 xi 109 спецификация выхода: запишите в выходной файл числа xi в порядке неубывания. пример входа: 5 12 10 5 10 7 пример выхода: 5 7 10 10 12
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Giurievna1977
arnika-ooo1
borodin
natachi
Лежачёва355
ikuvila5484
varvv15
lena260980
armentamada1906
nalich8524
soa8690
morozovalexander90
vladimyrgorbunov
Андреевна-Арзуманян1109
nmakarchuk