kenni19868
?>

Решить в паскале. с клавиатуры вводится слово. составить программу, которая запрашивает ввести следующее слово, которое начинается с последней буквы предыдущего и осуществляет проверку. результатом программы является сообщение "правильно" или "неправильно"

Информатика

Ответы

ilma20168
Var s,t,l,k: string; begin writeln ('введите два слова так, чтобы второе начиналось с последней буквы первого'); readln (s); readln (t); s: =lowercase (s); t: =lowercase (t); l: =s[length(s)]; k: =t[1]; if (l=k) then writeln ('правильно') else writeln ('неправильно'); end.
иванович Диденко1524
Function sq(a,b,c: real): real; var p: real; begin p: =(a+b+c)/2; result: =sqrt(p*(p-a)*(p-b)*(p-c)) end; function tr(a,b,c: real): boolean; begin result: =(a+b> c)and(a+c> b)and(b+c> a) end; var a,b,c,k1,k2,h,t,s,r1,r2: real; begin writeln(' найти радиус или площадь треугольника? если радиус,то нажмите 1. если площадь, то нажмите 2 '); readln(k1); if k1=1 then    begin    writeln('окружность вписанная(нажмите 1) или описанная(нажмите 2)? ');   readln(k2);   write('сторона а = ');   readln(a);   write('сторона b = ');   readln(b);   write('сторона с = ');   readln(c);   if tr(a,b,c) then   begin   s: =sq(a,b,c);   if k2=1 then    begin   r1: =(a+b+c)/(2*s);   writeln('радиус вписанной окружности = ' , r1);   end;   if k2=2 then    begin   r2: =a*b*c/(4*s);   writeln('радиус описанной окружности = ', r2);   end;   end else writeln('треугольник не существует');   end else   if k1=2 then   begin   writeln('что вам известно? если а и h, то нажмите 1. если а,b,с то нажмите 2' );   readln(k2);   if k2=1 then   begin   write('высота = ');   readln(h);   write('cторона = ');   readln(t);   s: =1/2*h*t;   writeln('площадь = ',s);   end;   if k2=2 then   begin   write('a = ');   readln(a);   write('b = ');   readln(b);   write('c = ');   readln(c);   if tr(a,b,c) then     begin     s: =sq(a,b,c);     writeln('площадь = ',s) ;     end else writeln('треугольник не существует');   end;   end; end. пример:   найти радиус или площадь треугольника? если радиус,то нажмите 1. если площадь, то нажмите 2  2 что вам известно? если а и h, то нажмите 1. если а,b,с то нажмите 2 1 высота = 3 cторона = 4 площадь = 6
озерская_Мария1234
// pascalabc.net 3.2, сборка 1385 от 14.02.2017 // внимание! если программа не работает, обновите версию! begin   var a: =arrrandom(20,-50,50); a.println;   writeln('a[5]=',a[4]) end. пример -11 16 -26 -2 23 0 13 34 49 50 -40 20 -50 18 24 -5 -42 38 27 -23 a[5]=23 если пятый элемент в первой строке надо при выводе пропустить, то так: begin   var a: =arrrandom(20,-50,50); (a[: 4]+a[5: ]).println;   writeln('a[5]=',a[4]) end. пример 21 39 45 -22 -17 11 45 -26 8 46 23 12 25 36 -46 -39 -40 49 40 a[5]=-32

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить в паскале. с клавиатуры вводится слово. составить программу, которая запрашивает ввести следующее слово, которое начинается с последней буквы предыдущего и осуществляет проверку. результатом программы является сообщение "правильно" или "неправильно"
Ваше имя (никнейм)*
Email*
Комментарий*