s777tver109
?>

Составить алгоритм решения согласно своему варианту и написать программу на языке с++. в отчете предоставить блок-схемы функции : вводится последовательность целых чисел, 0 – конец последовательности.для каждого числа последовательности проверить, представляют ли его цифры строго возрастающую последовательность, например, 1234(результатом функции будет 1 – да, 0 - нет

Информатика

Ответы

kuzinnv1968
#include < iostream> int main() {     int n;     bool flag = true;     std: : cin > > n;     while(n ! = 0) \\! ожидаем появления на входе нуля     {         while (n > = 10)          {             if(n / 10 % 10 > = n % 10) \\! сравниваем две последние цифры в числе                 flag = false; \\! если не совпадает с условием, flag = false, т.е. выведется 0             n = n / 10;         }         std: : cout < < flag < < std: : endl;         flag = true;         std: : cin > > n;     } }
sinicin80
Трещит, а не кузнечик, не водопад – шумит. хоть рта он не имеет, но внятно говорит. за ним – сидим, за  ним – едим, он всей  семье необходим. на компьютерном столе она мне. колесиком и кнопкой я ловко. он круглый и блестящий, с пластинкою похож, но меньше он, изящней, и современней все ж. на нем хранится много всего,что ты захочешь. вот вставишь в дисковод его, читаешь все, что хочешь. есть у этого предмета только чистые листы. робко  ждут листочки эти, что на них напишешь ты что-то важное, святое, что никак нельзя забыть. без которого не стоит даже в этом мире жить. стоит здание кто в него войдет,  тот ум приобретет. 1)телефон 2)стол 3)мышка 4)диск 5)записная книжка 6)школа    
Владимир
Var     i,j,p: integer;     a: array[1..10]of integer; begin writeln('исходный массив: '); for i: =1 to 10 do   begin   a[i]: =random(5,150);   write(a[i],' ');   end; writeln; for i: =1 to 10 do     for j: =i to 10 do     if a[j]> a[i] then       begin       p: =a[i];       a[i]: =a[j];       a[j]: =p       end; writeln('отсортированный массив: '); for i: =1 to 10 do  write(a[i],' '); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить алгоритм решения согласно своему варианту и написать программу на языке с++. в отчете предоставить блок-схемы функции : вводится последовательность целых чисел, 0 – конец последовательности.для каждого числа последовательности проверить, представляют ли его цифры строго возрастающую последовательность, например, 1234(результатом функции будет 1 – да, 0 - нет
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

s9152992722344
Lidburg
Zhamynchiev
Ka-tja78
misspodvigina
впвыпвып-Зуйков629
nataljatchetvertnova
abroskin2002
dimaproh
Ivan1568
AndreiFaikov1943
annapiskun1
lele4kass
langprint
Vs1377