iv1as2
?>

Напишите программу, которая получает два целых числа и находит их произведение не используя операцию умножения. учтите, что числа могут быть отрицательными.пример : введите два числа: 10-15, 10*(-15)=-150

Информатика

Ответы

jenn055
Var  a, b, prod, i: integer; begin   writeln('введите два числа: ');   readln(a, b);   prod : = 0;   if (b < 0) then     for i : = b to -1 do       dec(prod, a)   else     for i : = 1 to b do       inc(prod, a);   writeln(prod) end.
artem-dom
1. перевод текста с языка на можно назвать:   б) информационным процессом обработки информации; 2. измерение температуры представляет собой в) процесс получения 3. перевод текста с языка на можно назвать:   в) процесс полученияд) процесс использования. 4. записная книжка обычно используется с целью: г) хранения, обработки и передачи информации; 5. примером передачи информации может служить процесс: а) отправление телеграммы  6. какие из перечисленных процессов являются информационными: б) процессы получения, поиска, хранения, передачи, обработки и использования информации 7. под носителем информации понимают: в) среду для записи и хранения информации 
Попова1271
№1 1) названием программы не может быть оператор end 2) ошибок нет 3) неверно написан оператор (нужно programm, вместо programma) №2 1) неправильно записан оператор mod. неправильно написан знак присваивания (: =) 2) неправильно записан оператор div.  неправильно написан знак присваивания (: =) 3) недостаточно аргументов.  неправильно написан знак присваивания (: =) 4) неправильно записан оператор div.  неправильно написан знак присваивания (: =). лишний символ ^ №3 1) 1 2) ошибка 3) 4 4) 5 5) 64 6) 10 7) 81 №4 вообще, здесь должна быть ошибка, потому что неверно записан знак если представить, что там все правильно, тогда: b=4680 a=4682

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая получает два целых числа и находит их произведение не используя операцию умножения. учтите, что числа могут быть отрицательными.пример : введите два числа: 10-15, 10*(-15)=-150
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Энверович
eduard495
rykovatv6
simplexsol
zabava-83
Александровна
julkamysh9
Tatianarogozina1306
corneewa20096
gutauta6
Verakravez8790
nelli-bi6
ntyremsk1
Vello Olga
muz-cd