natalili32
?>

Составить программу. сформировать массив из 8 элементов, вывести количество отрицательных чисел. составить программу. создать массив из 10 элементов случайным образом, найти сумму нечетных чисел. писать на языке паскаль, одномерный массив

Информатика

Ответы

vovababkin1477
Program tref; var a,i: integer; mas: array[1..8]of integer; begin for i: =1 to 8 do begin mas[i]: =random(20)-10; writeln(mas[i]: 3); if(mas[i]< 0)then a: =a+1; end; writeln(a); end.program tref; var a,i: integer; mas: array[1..10]of integer; beginfor i: =1 to 10 dobeginmas[i]: =random(20)-10; writeln(mas[i]: 3); if(mas[i]< 0)then a: =a+mas[i]; end; writeln(a); end.
Раисовна878
Type tbank=record name: string; curs: real; end; var banks: array[1..15] of tbank; max,dollars: real; i,mi: longint; begin write('you have: '); readln(dollars); for i: =1 to 15 do begin write('bank name: '); readln(banks[i].name); write('curs: '); readln(banks[i].curs); end; max: =dollars*banks[1].curs; mi: =1; for i: =2 to 15 do begin if(dollars*banks[i].curs> max) then begin max: =dollars*banks[i].curs; mi: =i; end; end; writeln('best bank name: ',banks[mi].name,', curs is : ',banks[mi].curs: 2: 2,', we will get: ',max: 2: 2,', rub.'); end.
musaevartur

ответ:

объяснение:

кодирование текстовой информации

текстовая информация состоит из символов: букв, цифр, знаков препинания и др. одного байта достаточно для хранения 256 различных значений, что позволяет размещать в нем любой из алфавитно-цифровых символов. первые 128 символов (занимающие семь младших бит) стандартизированы с кодировки ascii (american standart code for information interchange). суть кодирования заключается в том, что каждому символу ставят в соответствие двоичный код от 00000000 до 11111111 или соответствующий ему десятичный код от 0 до 255. для кодировки букв используют различные кодовые таблицы (коi-8r, ср1251, cp10007, iso-8859-5):

koi8r — восьмибитовый стандарт кодирования букв кириллических алфавитов (для операционной системы unix). разработчики koi8r поместили символы алфавита в верхней части расширенной таблицы ascii таким образом, что позиции кириллических символов соответствуют их фонетическим аналогам в алфавите в нижней части таблицы. это означает, что из текста написанного в koi8r, получается текст, написанный латинскими символами. например, слова «дом высокий» приобретают форму «dom vysokiy»;

ср1251 – восьмибитовый стандарт кодирования, используемый в os windows;

cp10007 - восьмибитовый стандарт кодирования, используемый в кириллице операционной системы macintosh (компьютеров фирмы apple);

iso-8859-5 – восьмибитовый код, утвержденный в качестве стандарта для кодирования языка.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу. сформировать массив из 8 элементов, вывести количество отрицательных чисел. составить программу. создать массив из 10 элементов случайным образом, найти сумму нечетных чисел. писать на языке паскаль, одномерный массив
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Ivanova.i.bkrasheninnikov
orange-salon-job77
Овчинников_Грузман
Natakarpova75732
Vadim443
ivanpetrovichru1801
pavlova7771960
omigunova39
Svetlana395
info8
znaberd786
lazu8375
vfilina
Борисович409
vettime625