Aleksandrovich1415
?>

Написать программу на паскаль дано натуральное число. вычислить количество цифр, являющихся степенями тройки (1, 3, 9

Информатика

Ответы

Решетникова
Var n, digit, ans : integer; begin     read(n);     ans : = 0;     while (n > 0) do begin         digit : = n mod 10;         if ((digit = 1) or (digit = 3) or (digit = 9)) then             ans : = ans + 1;         n : = n div 10;     end;     writeln(ans); end.
Николаевна Филиппов1936
Var  a,b,c,n: integer; begin for a: =1 to 7 do   for b: =a+1 to 8 do     for c: =b+1 to 9 do       begin       n: =a*100+b*10+c;       write(n: 4)       end; end.var    i,j,n: integer;     a: array[1..4,1..5]of real; beginfor i: =1 to 4 do  begin  for j: =1 to 5 do    begin    a[i,j]: =random*2-1;     write(a[i,j]: 20: 15);     if a[i,j]> =0 then n: =n+1;     end;   writeln;   end; writeln('количество неотрицательных: ',n); end.var    i,j,sum: integer;     a: array[1..3,1..4]of integer; beginfor i: =1 to 3 do  for j: =1 to 4 do    readln(a[i,j]); writeln('массив: '); for i: =1 to 3 do  begin  for j: =1 to 4 do    begin    sum: =sum+a[i,j];     write(a[i,j]: 4);     end;   writeln('sum=': 8,sum);   sum: =0;   end; end.
vallium8354
Проведем некоторые преобразования. наиболее вероятное предположение, что s2 - формула площади круга с диаметром dr, а s1 - формула площади квадрата со стороной a и диагональю dg. в программа сравнивается диагональ квадрата и диаметр окружности и если диагональ меньше диаметра, выводится "да", в противном случае выводится нет. это позволяет сделать предположение о следующей постановке : "можно ли поместить брусок квадратного сечения с площадью s1 в полый цилиндр с площадью основания s2 ? ". или, как вариант, пройдет ли брусок в отверстие..

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на паскаль дано натуральное число. вычислить количество цифр, являющихся степенями тройки (1, 3, 9
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

dimanov
Игоревна Худанов1150
turaev-1098
gilmore886173
Igor1406
kryukovaem
Anastasiya Yevseeva948
Вячеславовна_Сагитович
по ICT надо в паскале решить​
Сергеевна-Пузанов
Reutskii-Kirilovskii1625
Можарова14
avolodyaev
zaschitin48
yliana
kon200182