Надо! дано целое число n, которое больше либо равно 0 и меньше либо равно 9. написать программу, вычисляющую сумму всех двузначных чисел в записи которых нет n.
Var n,i,one,dec,sum: integer; begin writeln('введите n'); readln(n); sum: =0; for i: =10 to 99 do begin one: = i mod 10; dec: =i div 10; if (one< > n)and(dec< > n) then sum: =sum+i; end; writeln(sum); readln end.
Киларджиева Диана440
06.08.2022
2. 52 div 8 = 6 целое 2+6=8 целое √8≈2.828 вещественное trunc(2.828)=2 целое 15 mod 4=3 целое 3/3=1 целое 2-1=1 целое ответ: 1, тип целое 3. максимальное значение integer в языке паскаль зависит от реализации. стандарт языка определяет, что под переменную типа integer необходимо отвести объем памяти, достаточный для хранения значения 32767, т.е. в связи с этим в ранних реализациях паскаля под переменные типа integer отводилось 2 байта памяти. в современных реализациях под переменные этого типа отводится 4 байта, поэтому максимальное значение integer может достигать или 2147483647.4. если надо сохранить целое число, большее в 10 раз максимального значения integer, то нужно для поинтересоваться а) сколько байт отводится под integer? б) есть ли в данной реализации паскаля целые числа, под хранение которых отводится большее число байт? когда integer двухбайтовое, следует использовать четырехбайтное longint, а когда четырехбайтное - поинтересоваться наличием восьмибайтного типа int64.
shabaev19542355
06.08.2022
Для начала посчитаем, сколько бит информации было передано: 2 минуты и 45 секунд = 165 секунд 165 с * 128000 бит/с = 21120000 бит теперь вспомним, что такое частота дискретизация и уровни квантования. дело в том, что аудио сигнал - это такая прикольная сложная синусоида. чтобы записать сигнал в цифровом виде, каждую секунду сигнала как бы делят на промежутки (количество этих промежутков в секунде и есть частота дискретизации). для каждого из этих промежутков записывается что-то вроде среднего значения высоты. количество возможных значений - количество уровней квантования. но это так - если говорить . подробнее прочитайте в своём учебнике информатики. итак - у нас 256 уровней квантования. значит каждое из значений можно записать 8 битами. и на секунду у нас приходится 22000 таких записей. то есть каждая секунда записи у нас кодируется 22000 * 8 = 176000 битами. 21120000 / 176000 = 120 секунд.
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Надо! дано целое число n, которое больше либо равно 0 и меньше либо равно 9. написать программу, вычисляющую сумму всех двузначных чисел в записи которых нет n.