Usynin-nikolay
?>

30ку.написать программу на паскале которая определяет и выводит все составные числа n. число n задается во время работы программы

Информатика

Ответы

Kondratev Ruzavina22

ответ:

. в нужно вывести все составные числа из промежутка [2; n]. код программы:

program lab3;

var i,n,j,s,l: integer;

m: real;

begin

readln (n);

for i: =2 to n do

begin

s: =trunc (sqrt (i));

for l: =2 to s do

begin

m: = i mod l;

if m=0 then

write (' ',i);

end;

end;

end.

но проблема - как только s становится больше 2, составные числа начинают несколько раз повторятся, т.к., например 12 делится и на 2 и на 3. вопрос: как мне сделать выход из цикла после первого успешного деления?

var

i, n, j, s, l: integer;

m: real;

begin

readln(n);

for i : = 2 to n do

begin

s : = trunc(sqrt(i));

for l : = 2 to s do

begin

m : = i mod l;

if m = 0 then

begin

write(' ', i);

break;

pri02

Объяснение:

Повреждение рабочих файлов программы. Причин этому тоже может быть значительное количество. Чаще всего это происходит при использовании некачественных репаков, попытке взломать лицензионную версию проги и её несовместимости со взломщиком, некорректной установке обновлений программы, а также действие вредоносного софта.

Нарушение прав использования программы отдельными пользователями. В основном происходит в том случае, когда компьютером пользуются несколько людей через свою учётную запись. Если при установке не выбрать параметры «Разрешить всем пользователям», или в настройках учётных записей Windows не дать разрешение на использование CorelDRAW, у этого пользователя программа работать не будет.

osandulyak

Цей електронний підручник знайомить з мовою програмування Python. Навчальний матеріал у ньому систематизований за розділами і є введенням у програмування від основ до поглиблених тем.

Розділи включають у себе: теоретичні відомості з практичними прикладами, контрольні запитання, вправи і задачі для самостійного виконання, довідкові матеріали.

Зразки розв’язування вправ і задач, які наведені у підручнику, можна переглянути у програмному застосунку Simple File Manager , що є додатком до підручника. Якщо Ви бажаєте відразу перейти до практики і перевірити свої сили у створенні програм мовою Python, використайте Практикум з програмування мовою Python .

Підручник призначений як для програмістів-початківців так і для тих, хто вже створював програми на інших мовах програмування, але бажає перевірити своє розуміння алгоритмів, використовуючи мову Python.

Робота із підручником передбачає, що Ви:

Володієте навичками роботи в операційній системі (Windows або Linux) на рівні користувача.

Підручник стане у нагоді всім, хто зацікавлений у вивченні популярної мови програмування Python, незалежно від того, чи вивчали ви інші мови програмування раніше.

Объяснение:

Цей електронний підручник знайомить з мовою програмування Python. Навчальний матеріал у ньому систематизований за розділами і є введенням у програмування від основ до поглиблених тем.

Розділи включають у себе: теоретичні відомості з практичними прикладами, контрольні запитання, вправи і задачі для самостійного виконання, довідкові матеріали.

Зразки розв’язування вправ і задач, які наведені у підручнику, можна переглянути у програмному застосунку Simple File Manager , що є додатком до підручника. Якщо Ви бажаєте відразу перейти до практики і перевірити свої сили у створенні програм мовою Python, використайте Практикум з програмування мовою Python .

Підручник призначений як для програмістів-початківців так і для тих, хто вже створював програми на інших мовах програмування, але бажає перевірити своє розуміння алгоритмів, використовуючи мову Python.

Робота із підручником передбачає, що Ви:

Володієте навичками роботи в операційній системі (Windows або Linux) на рівні користувача.

Підручник стане у нагоді всім, хто зацікавлений у вивченні популярної мови програмування Python, незалежно від того, чи вивчали ви інші мови програмування раніше.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

30ку.написать программу на паскале которая определяет и выводит все составные числа n. число n задается во время работы программы
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

alexandergulyamov
Щуплова Александр
Abespal
annarom1306
Роман1406
veronica1344
pronikov90
ilds88
lechic3
vis-lyubov8832
petrovichvit2933
kate281078
anastasiavilina
euzdenova
deniskotvitsky56