vasilevam
?>

1. с клавиатуры последовательно вводятся десять чисел. написать программу на паскале, которая вычислит и выведет на экран сумму чисел, кратных 3. 2. с клавиатуры вводится число n. написать программу, которая вычислит и выведет на экран все его делители

Информатика

Ответы

timonina29
Ввод с клавиатуры одномерного массива целых чисел и вывод его элементов на экран с противоположным знаком program massiv2;       const n=10;     type {  раздел описания типов переменных. эти типы определяет сам пользователь, то есть мы определяем тип одномерного массива из n целых чисел  }        mas=array [1..n] of integer; {  1..n - тип индекса; для индекса выбран интервальный тип. то есть интервал целых чисел от 1 до n. где n определено в разделе const  }    var            line: mas; {  line - одномерный массив, его тип определен нами как mas  }            i: integer; {переменная, хранящая индекс элемента массива, к которому идет обращение  }begin{  ввод массива с клавиатуры  }    for i: =l to n do {  обращение к элементам массива происходит в цикле, по очереди  }        begin {  начало цикла ввода элементов массива  }            write('введите элемент с индексом ' ,i,' : ');             readln(line[i]) {  обращаемся к i-му элементу массива (line[l],line[2] и т. д.)}        end; {  конец цикла ввода элементов массива  }{  вывод элементов происходит также в цикле: }    for i: =l to n do {  перебираем все n элементов массива  }        write(-line[i]: 5); {  10 элементов выводятся в строку. выводим все элементы массива с противоположным знаком  }    writeln; {  после вывода массива элементов - переход на новую строку  }      readln  end.
Yeliseeva Verevkin864
Длительность не превышает 10 минут, то есть 10*60=600 секунд. для удобства переведём скорость из кбит/сек в кбайт/сек по формуле кбит/8=кбайт 32 кбит/с / 8 = 4 кбайт/с то есть за 1 секунду передаётся 4 кбайт, значит за 600 секунд будет передано 600*4= 2400 кбайт  соглашусь с alviko, вариант 2: за секунду передаётся 32 кбит, то есть 32 000 бит. переводим в байты (делим на 8), получаем 4000 байт/с.  на передачу уходит максимум 600 секунд, то есть за 600 секунд будет передано 4000*600=2  400  000 байт. переведём байты в килобайты (разделим на 1024) 2  400  000 байт / 1024 =  2343,75 кбайт в не сказано, целое ли количество кбайт требуется в ответе. если целое, то ответ  2343 кбайт (округляем в меньшую сторону, т.к.  2344 кбайт за 10 минут мы передать не можем).
v89167233402
Создаешь цикл for , который записывает номера array[ i ].numer;   в отдельный массив . затем массив  прогоняешь массив циклом for и ищешь максимум (не забудь добавить переменную-счетчик что б он выводил не первый максимум, а только тогда, когда пройдет весь массив). затем выведенное число заменяешь на 0   . тебе понадобится еще одна переменная-счетчик, что бы после того как он выведет тебе все номера, он не начал выводить нули.костыльно конечно , но этот способ работает. успехов!

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. с клавиатуры последовательно вводятся десять чисел. написать программу на паскале, которая вычислит и выведет на экран сумму чисел, кратных 3. 2. с клавиатуры вводится число n. написать программу, которая вычислит и выведет на экран все его делители
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

blackpoint2020273
sergeykvik13
Ivanovich-A.V
YelenaZOLTANOVICh105
koldunovan
osipovasalex5316
kortikov77
artemy682719
d111180
Yuliya Aleksandr686
Alyona744
Buninilya
Овсянкина407
minchevaelena23
ИП-Сысоев1628