a1rwalk3r
?>

Реализуйте структуру данных "стек". напишите программу, содержащую описание стека и моделирующую работу стека, реализовав все указанные здесь методы. программа считывает последовательность команд и в зависимости от команды выполняет ту или иную операцию. после выполнения каждой команды программа должна вывести одну строчку. возможные команды для программы: push n добавить в стек число n (значение n задается после команды программа должна вывести ok. pop удалить из стека последний элемент. программа должна вывести его значение. back программа должна вывести значение последнего элемента, не удаляя его из стека. size программа должна вывести количество элементов в стеке. clear программа должна очистить стек и вывести ok. exit программа должна вывести bye и завершить работу. гарантируется, что набор входных команд удовлетворяет следующим требованиям: максимальное количество элементов в стеке в любой момент не превосходит 100, все команды pop и back корректны, то есть при их исполнении в стеке содержится хотя бы один элемент.

Информатика

Ответы

Svetlaru70
{$r+,s+,q+}  uses  sysutils;   const r=1000; type mas= array  [0..r]  of integer; var  a: mas;   en,n: integer;   x,y,z,q,w: char; function push(n: integer): string; begin   a[en]: =n;   en: =en+1;   push: ='ok'; end; function pop(): integer; begin   en: =en-1;   pop: =a[en];   a[en]: =0; end; function back(): integer; begin   back: =a[en-1]; end; function size(): integer; begin  size: =en; end; function clear(): string; begin   en: =0;   clear: ='ok'; end; function exit(): string; begin  exit: ='bye'; end; begin   en: =0;   repeat     read(x);     if x='p' then    begin       read(y);       if y='u' then      begin         read(z,q,w);         readln(n);         writeln(push(n))      end else begin         readln(z);         writeln(;       end;     end;     if x='b' then    begin       readln(y,z,q);       writeln(;     end;     if x='s' then begin       readln(y,z,q);       writeln(;     end;     if x='c' then begin       readln(y,z,q,w);       writeln(;     end;     if x='e' then begin       readln(y,z,q);       writeln(;     end;   until x='e'; end.
amarantmetall
№1 a) 12288 кб = (12288  :   1024) мб = 12 мб b) 1024 гб = (1024 * 1024) мб = 1048576 мб c) 2097152 байт = (2097152 : 1024 : 1024) мб = 2 мб№2 a) 3,2 мб = (3,2 * 1024 * 1024 * 8) бит = 26843545,6 бит b) 2 кб = (2 * 1024 * 8) бит = 16383 бит№3 a) 6144 кб = (6144 : 1024) мб = 6 мб b) 2048 гб = (2048 * 1024) мб = 2097152 мбc) 3145728 байт = ( 3145728  : 1024 : 1024 ) мб = 3 мб№4 a) 1,4 мб = (1,4 * 1024 * 1024 * 8) бит =   11744051,2 бит b) 8 кб = (8 * 1024 * 8) биьт = 65536 бит
Lyalikova

ответ:

приставка мега, согласно гост 8.417 от 2002 года и си, равена 10 в 6 степени, то есть мегабайт равен 1000 килобайт. вы всегда думали что 1 мб равен 1024 кб? это тоже верно! 1 мебибайт равен 1024 кибибайтам.

что же не так, нас обманывают? нет, просто производители жестких дисков, измеряют объем в десятичной системе измерения, а операционная система считает в двоичной, при этом как мегабайты, так и мебибайты можно сократить до мб — вот такое вот получается недопонимание.

то есть пока мы и производители считаем мегабайты, компьютеры считают мебибайты, а 1000 гигабайт равны 931,323 гибибайтам.

объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Реализуйте структуру данных "стек". напишите программу, содержащую описание стека и моделирующую работу стека, реализовав все указанные здесь методы. программа считывает последовательность команд и в зависимости от команды выполняет ту или иную операцию. после выполнения каждой команды программа должна вывести одну строчку. возможные команды для программы: push n добавить в стек число n (значение n задается после команды программа должна вывести ok. pop удалить из стека последний элемент. программа должна вывести его значение. back программа должна вывести значение последнего элемента, не удаляя его из стека. size программа должна вывести количество элементов в стеке. clear программа должна очистить стек и вывести ok. exit программа должна вывести bye и завершить работу. гарантируется, что набор входных команд удовлетворяет следующим требованиям: максимальное количество элементов в стеке в любой момент не превосходит 100, все команды pop и back корректны, то есть при их исполнении в стеке содержится хотя бы один элемент.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

MNA888
Freelifecool797
Alekseevich_Viktorovna
mkrtchyananaida6995
ser7286
picassovrn
ka-shop
Жукова_Петрович1281
annanas08
Тариелович871
zadvornovakrmst
alex-kuzora4411
eobmankina
udalova-yelena
▲