OlgaVasilevna
?>

Написать программу, вывод на экран последовательность из 10 чисел каждое из которых на 3 больше предыдущего.

Информатика

Ответы

aleksey270593
Program enot; var b,j,i: integer; begin read(b); for j: =1 to 9 do begin b: =b+3; writeln(b); end; end.
s777tver109

uses crt;

const raz=[' ','.',',','?','!'];{/разделители слов, можно добавить}

var s,sl:string;

   i,k:byte;

begin

clrscr;

writeln('Строка:');

readln(s);

writeln('Слово:');

readln(sl);

k:=0;

for i:=1 to length(s) do{идем по строке}

if(s[i]=sl[1])and((s[i-1] in raz)or(i=1)){если символ равен первому символу слова

а перед ним разделитель или начало строки}

and((s[i+length(sl)] in raz)or(i+length(sl)=length(s))){и после слова разделитетль или конец строки}

and(copy(s,i,length(sl))=sl){и все буквы на интервале равны слову}

then k:=k+1;{считаем}

write('Слово ',sl,' встречается ',k,' рз.');

readln

end.

Объяснение:

на каком языке? (В ответе паскаль)

gre4ka2004
#include < iostream> using namespace std; int main() { double a,b,c,max,min; int kp,kn,kz; cin> > a> > b> > c; kp=kn=kz=0; if (a> 0) kp++; else if (a==0) kz++; else kn++; if (b> 0) kp++; else if (b==0) kz++; else kn++; if (c> 0) kp++; else if (c==0) kz++; else kn++; if (a> b)     if (a> c) { max=a; min=(b> c) ? c : b; }     else { max=c; min=b; } else     if (b> c) { max=b; min=(a> c) ? c : a; }     else { max=c; min=a; } double mid=(a+b+c)/3; cout< < "polozhit: "< < kp< < ", nulevykh: "< < kz< < ", otritsat: "< < kn< < endl; cout< < "min="< < min< < ", max="< < max< < ", srednee="< < mid< < "\n"; system("pause"); } тестовое решение: -1.76 2.18 -0.543 polozhit: 1, nulevykh: 0, otritsat: 2 min=-1.76, max=2.18, srednee=-0.041 для продолжения нажмите любую клавишу . .

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, вывод на экран последовательность из 10 чисел каждое из которых на 3 больше предыдущего.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Araevich
Minchenkova
Lusiarko65
VadimovnaIgor
elena
Суховодова599
ksenia15-79
Окунева-Мотова
shuramuji
energycomplect5914
antilopa001
Anatolevich_Kulikov1229
amarantmetall
Герасименко
yuliyastatsenko3894