topsalon
?>

Python напишите программу, которая получает с клавиатуры возрасты трёх человек (антона, бориса и виктора) и определяет, кто из них старше. заранее !

Информатика

Ответы

манукян29

var

  s : string;

  i : integer;

  f : boolean;

begin

  readln (s);

  writeln ('тут ', length (s), ' символов');

  f : = true;  

for i : = 1 to length (s) div 2 do

    if s[i] < > s[length (s) - i + 1] then f : = false;

  writeln ('это слово является перевертышем: ', f); //true/false

end.

 

var

  s : string;

  i, k, count : integer;

  c : char;

begin

  readln (s);

  count : = 0;

  for i : = 1 to length (s) do

    if s[i] < > ' ' then

    begin

        c : = s[i];

        k : = i + 1;

        break;

    end;

  for i : = k to length (s) do

    if (s[i] = ' ') and (c < > ' ') then

    begin

        if s[i - 1] = c then inc (count);

        c : = ' ';

    end

    else if c = ' ' then c : = s[i];

  if (c < > ' ' ) and (s[length (s)] < > ' ') and (c = s[length (s)]) then inc (count);

  writeln (count);

end.

Lenuschakova1982316

таблица - рейсы

ид

название

ид начального пункта

ид конечного пункта

 

таблица - пункты (остановки)

ид

название

 

таблица - растояние+рейс

ид пункта1

ид пункта2

растояние (растояние между пунктами 1 и 2, пункты должны быть только соседними)

ид рейса

цена (стоимость проезда между пунктами 1 и 2)

 

таблица - автобусы

ид

потребление топлива (на 1 км)

кол-во посадочных мест

 

таблица - рейс+автобус (какие автобусы по каким рейсам ездят)

ид рейса

ид автобуса

 

таблица - билеты

ид рейс

дата-время

кол-во проданных билетов

 

таблица - сотрудники

ид

имя

должность

ставка

телефон

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Python напишите программу, которая получает с клавиатуры возрасты трёх человек (антона, бориса и виктора) и определяет, кто из них старше. заранее !
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Urmanov19903131
Olesya-elena1525
Taurus59707
Sharap
alvas12828646
Shumnova42
char40
uksusoval617
alexanderpokrovskij6
ragimovelshad
alukyanov
Лилит_Шутова
iptsr4968
ajuli2
deshkina82