amaraks67
?>

Синформатикой. нужно составить программу которая удалит из текста все цифры( использование pos, copy, delete, insert)

Информатика

Ответы

Захаров-Иванович
For i: =1 to length(s) do if s[i] in ['1'..'9'] then sum: =sum+ord(s[i])-48; //здесь ноли не считаем, от них сумма не меняется writeln('сумма цифр в тексте='sum); if sum> 5 then   begin   for i: =lengrh(s) downto 1 do   if s[i] in ['0'..'9'] then delete(s,i,1);   write(s);   end else write('цифры не удаляются! ');
llmell6
Виды биометрической идентификации личности

В наши дни необыкновенно востребованной оказалась биометрическая идентификация личности. Выделяют следующие биометрические системы:

биометрия по голосу;
биометрия по чертам лица (характерные точки на лице человека);
биометрия по папиллярному рисунку пальца человека;
биометрия по строению вен пальца или ладони;
биометрия по строению радужной оболочки глаза;
биометрия по сетчатке глаза;
биометрия по ДНК;
биометрия по почерку;
биометрия по особенностям набора текста на клавиатуре ПК;
биометрия по термограмме лица;
биометрия по форме ушной раковины;
биометрия по походке;
биометрия по отражению ИК-потока от кожи;
биометрия по движению губ;
биометрия по запаху тела;
биометрия по кардиограмме;
биометрия по геометрии кисти руки.
Очевидно, что приведенный список неполный, но основные системы в нем указаны.
daverkieva568

const N = 10;

var

   a: array[1..N] of integer;

   i: byte;

   avrg: real;

   sum: integer;

begin

   randomize;

   for i:=1 to N do a[i]:=random(50)+1;

   sum := 0;

   for i:=1 to N do sum := sum + a[i];

   avrg := sum/N;

   

   // весь массив

   for i:=1 to N do write(a[i]:3);

   writeln;

   

   writeln('Среднее арифм.: ',avrg:4:2);

   

   // больше avrg    

   for i:=1 to N do if a[i]<avrg then write(a[i]:3);

   writeln;

end.

Объяснение:

Алгоритм решения задачи:

1. Посчитать сумму всех элементов массива. Для этого до цикла вводится переменная для суммы (например, sum). Далее в цикле перебираются элементы массива и значение каждого добавляется к этой переменной. Подсчет суммы можно выполнить в том же цикле, что и заполнение массива.

2. Когда сумма элементов посчитана, находится среднее арифметическое, которое равно сумме разделенной на количество элементов массива.

3. Массив перебирается в цикле, каждый элемент сравнивается с найденным средним значением. Если элемент меньше, то он выводится на экран (или сохраняется в другом массиве).

Скопировал с сайта сразу говорю.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Синформатикой. нужно составить программу которая удалит из текста все цифры( использование pos, copy, delete, insert)
Ваше имя (никнейм)*
Email*
Комментарий*