Составьте программу, которая позволяет переставить местами cлова строки s. строка s , состоящая из двух слов, разделённых пробелом, вводится с клавиатуры.
program pr1; uses crt; var stroka,tmp: string; i: integer; beginclrscr; readln(stroka); for i: =1 to length(stroka) do if stroka[i]=' ' then tmp: =copy(stroka,1,i-1); delete(stroka,1,length(tmp)+1); stroka: =stroka+' '+tmp; writeln(stroka); end.
citioil15
25.06.2020
< ! doctype html> < html> < head> < meta charset="utf-8"> < title> < /title> < /head> < body> < script> var a = +prompt("введите а",""); var b = +prompt("введите в",""); var h = +prompt("введите h",""); var s = ((a + b) / 2) * h; document.write("< h3> ответ: < /h3> < br /> < p> площадь равна: " +s+"< /p> "); < /script> < /body> < /html>
larinafashion829
25.06.2020
Const n = 10; var mas: array [1..n] of integer; i,x,j,a,b,index: integer; begin write('введите диапазон от a до b: '); readln(a,b); for i: = 1 to n do begin mas[i]: =random(b-a+1)+a; end; writeln('полученный массив: '); for i: = 1 to n do write(mas[i]: 4); for i: =n downto 1 do if mas[i]> 0 then begin index: =i; break end; mas[index]: =mas[2]; writeln; writeln('результат выполнения : '); for i: = 1 to n do write(mas[i]: 4); readln end. введите диапазон от a до b: 10 40 полученный массив: 25 13 38 31 39 12 16 11 26 33 результат выполнения : 25 13 38 31 39 12 16 11 26 13
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Составьте программу, которая позволяет переставить местами cлова строки s. строка s , состоящая из двух слов, разделённых пробелом, вводится с клавиатуры.
program pr1; uses crt; var stroka,tmp: string; i: integer; beginclrscr; readln(stroka); for i: =1 to length(stroka) do if stroka[i]=' ' then tmp: =copy(stroka,1,i-1); delete(stroka,1,length(tmp)+1); stroka: =stroka+' '+tmp; writeln(stroka); end.