suhanowaswetlana
?>

Написать программу, которая для первых n натуральных чисел находит сумму чётных и произведение нечётных чисел. число n вводится с клавиатуры . выполнить программу для n=13 , записать результат

Информатика

Ответы

kapriz1999
Const n=13; var i,s,p: integer; begin s: =0; p: =1; for i: =1 to n do begin if (i mod 2 = 0) then s: =s+i; if (i mod 2 < > 0) then p: =p*i; end; writeln("сумма четных = ",s," , произведение нечетных =",p); end.
shmanm26
Const n = 15; var a: array[1..n]of integer; i,m,min5: integer; f: boolean; begin   for i: =1 to n do begin       write('введите ',i,' член массива ');       readln(a[i]);       if a[i] mod 5=0 then begin           m: =m+1;           if not f then begin               min5: =a[i];               f: = not f;           end;           if (f) and (a[i]< min5) then min5: =a[i];       end;   end;   writeln('кратных 5: ',m: 3,' минимальный: ',min5: 4); end. тестовое решение введите 1 член массива 13 введите 2 член массива 10 введите 3 член массива 15 введите 4 член массива 5 введите 5 член массива 25 введите 6 член массива 23 введите 7 член массива 12 введите 8 член массива 32 введите 9 член массива 11 введите 10 член массива 21 введите 11 член массива 43 введите 12 член массива 15 введите 13 член массива 25 введите 14 член массива 13 введите 15 член массива 14 кратных 5:   6    минимальный:   5
Pgr100
1. программа в одной из современных версий паскаля: // pascalabc.net 3.1, сборка 1211 от 31.03.2016 begin   var s: =readlnstring('исходная строка: ');   writeln('результат: ',s.matchvalues('[a-za-zа-яа-яёё]').joinintostring('')); end. тестовое решение: исходная строка: // pascalabc.net 3.1, сборка 1211 от 31.03.2016 результат: pascalabcnetсборкаот 2. программа в "школьной версии" // pascalabc.net 3.1, сборка 1211 от 31.03.2016 const   legal=['a'..'z','a'..'z','а'..'я','а'..'я','ё','ё']; var   s: string;   i: integer; begin   write('исходная строка: '); readln(s);   for i: =length(s) downto 1 do       if not(s[i] in legal) then delete(s,i,1);   writeln('результат: ',s); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая для первых n натуральных чисел находит сумму чётных и произведение нечётных чисел. число n вводится с клавиатуры . выполнить программу для n=13 , записать результат
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

pavtrusov
Kati2005
Баринова
Татьяна Марина1287
artemiusst
snk7777202
Dmitrievna405
sirenashop25
Инна_Nina1182
yuklimochkina3
Шиморянов Мария1866
uzunanna19922488
Nadezhda
olgaprevisokova302
elenalukanova
▲