Написать программу которая находит произведение n первых натуральных чисел . число n вводится с клавиатуры. выполнить программу для n=9 записать результат.
Cont n=9; var i,p: integer; begin p: =1; for i: =1 to n do p: =p*i; writeln("произведение первых ",n," чисел = ",p); end.
Prostofil200790
02.02.2020
Немногие древние народы могут похвастаться таким количеством изобретений, изменивших судьбу человечества, как финикийцы: корабли и пурпур, прозрачное стекло и алфавит. пусть не всегда они сами были их авторами, но именно они внедряли эти находки и усовершенствования в жизнь, а также популяризовали их. последнее из перечисленных изобретений во многом определило судьбу современной цивилизации. мир был бы совсем иным, если мы не располагали бы самой простой и удобной системой письма из всех, что когда-либо были созданы человечеством. эту систему придумали финикийцы. создание алфавита – величайшее культурное достижение финикийцев. с их родины, с узкой береговой полоски на территории современного ливана, алфавит начал триумфальное шествие по миру. в городе угарите нашли памятники, покрытые клинописью. тридцать алфавитных знаков. в городе библосе нашли две бронзовые таблички, покрытые письменами – иероглифами. настоящий алфавит был создан в х веке до н.э. – 22 знака. каждая буква соответствует одному согласному или полусогласному звуку. финикийцы не писали гласные буквы. они объездили много стран, знали системы письма этих стран. у кого позаимствовали алфавит неизвестно. названия финикийских букв соответствуют названию тех предметов, форму которых эти буквы напоминали: •алеф – голова быка, •бет – дом, •гимель – угол. «алфавит» – это две первые буквы. «бет» иногда произносилось, как «вита», «алеф» + «вита».
ganna1790
02.02.2020
var result = 0; var kind = prompt("укажите вводимую величину: 1)метр2)сантиметр3)киллометр"); if (kind === "1") { var input = prompt("укажите кол-во: "); result = ((100 * input) / 2.54).tofixed(4); alert(input + " m =" + result + " in"); } else { if (kind === "2") { var input = prompt("укажите кол-во: "); result = (input / 2.54).tofixed(4); alert(input + " cm = " + result + " in"); } else { if (kind === "3") { var input = prompt("укажите кол-во: "); result = ((1000 * input) / 2.54).tofixed(4); alert(input + " km = " + result + "in"); } else { alert("не верно выбрана величина! "); } } }
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Написать программу которая находит произведение n первых натуральных чисел . число n вводится с клавиатуры. выполнить программу для n=9 записать результат.