Составьте программу, в которой функция выведет на экран однозначные числа, удовлетворяющие следующему условию: х*х*х-х*х=n , где n вводится с клавиатуры.
Var n,i: integer; begin readln(n); for i: =1 to 9 do if i*i*i-i*i=n then writeln(i) end.
akakne86
25.01.2021
Нужно 8 бит. 129 словам присваиваем номера от 0 до 128 в десятичной системе. 0(10)=0(2), 128(10)=10000000(2). если словам присваивать номера от 1 до 129, то понадобится тоже 8 бит, только 129(10)=10000001(2) для перевода можно пользоваться простым методом 129/2 = 64 с остатком, записываем 1 64/2 =32 без остатка, записываем 0 32/2 =16 без остатка, записываем 0 16/2 =8 без остатка, записываем 0 8/2 =4 без остатка, записываем 0 4/2 =2 без остатка, записываем 0 2/2 =1 без остатка, записываем 0 1/2 =0 с остатком, записываем 1 т.е. делим каждое частное на 2 и записываем наличие остатка в конец двоичной записи в виде остаток есть-1, остатка нет-0. деленим до тех пор, пока в частном не будет 0. результат записывается справа налево.
Kazantsevv_kostya
25.01.2021
1) переход от порядка к хаосу (уменьшение информации): - извержение вулкана: количество информации больше, когда горные породы находятся в спокойном состоянии, уменьшение информации выражается в том, что происходит выброс газов, горячего воздуха, пепла, разрушение горных пород, лава изливается; - ураган: частички песка и пыли поднимаются в воздух, уменьшается количество песка на поверхности земли - т.е. уменьшается количество информации 2) переход от хаоса к порядку: - муравьи строят муравейник (в хаотичном состоянии находятся иголки хвойных деревьев, мелкие палочки), - сбор меда пчелами в соты; - птицы для перелета собираются в стаи. 3. для сообщения: полезность, достоверность, краткость, актуальность для данного момента, независимость (от мнения и взглядов составителя сообщения) 4. для знаний: понятность, актуальность, научность, точность, полнота излагамых знаний. 5. автоматизированная линия на машиностроительном предприятии по сборке из деталей машины. системы в современных автомобилях - контроль за скоростью движения. системы самолетами: определение оптимального воздушного пути (траектории полета), система навигации - автоматическое предотвращение аварий и .д. 6. сообщения с 1 битом информации: - да / нет (на любой вопрос, который требует данного ответа) - выпал орел или решка - из двух цветов достали красный или черный - человек живет в одном из двух подъездов (в 1 или во 2)