ali13zakup5064
?>

Будем называть количество делителей числа n его красотой. например, красота числа 12 равна 6. требуется написать программу, которая по числу k (1 ≤ k ≤ 109) найдет число с максимальной красотой, не превышающее k.

Информатика

Ответы

asparinapti39
Program gt; var k,t,max,i,h,j,l: integer; begin readln(k); max: =0; for i: =1 to k do begin l: =round(sqrt(i)); h: =0; for j: =1 to l do if(i mod j=0)then h: =h+1; h: =2*h; if(l*l=i)then h: =h-1; if(h> max)then begin max: =h; t: =i; end; end; writeln(t); end.
Викторович Попков

1)

var

    a: real;

begin

    readln(a);

    writeln('s = ', 6 * a * a);

    writeln('v = ', a * a * a);

end.

2)  

var

    a, b, c: real;

begin

    readln(a, b, c);

    writeln('s = ', 2 * (a * b + b * c + a * c));

    writeln('v = ', a * b * c);

end.

3)

var

    r: real;

begin

    readln(r);

    writeln('p = ', 2 * 3.14 * r);

    writeln('s = ', 3.14 * r * r);

end.

kotsur
Var       i, k,n, max: integer;       f: boolean; begin       readln(k);       for i : = 1 to k do       begin               readln(n);               if (i = 1) or (max < n) then                       max : = n;               f: =f or (n=0);       end;       writeln(max,' ', f); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Будем называть количество делителей числа n его красотой. например, красота числа 12 равна 6. требуется написать программу, которая по числу k (1 ≤ k ≤ 109) найдет число с максимальной красотой, не превышающее k.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

tatianaesipenko
mgrunova
kettikis
bellatrixstudio
Васильевий
yda659
artemka56rus
Anna389
ank9809
Doronin755
Иванина
Дубровская571
bellenru
Суханова1532
julichca68