АнатольевичМиронова885
?>

Напишите программу увеличивающую каждый элемент матрицы (n, m) в 3 раза и сохраняющую результат в виде второй матрицы

Информатика

Ответы

Tatyana_Minullina
Uses   crt; const   nmax=40;   mmax=40; var   a,b: array[1..nmax,1..mmax] of integer;   i,j,n,m: integer; begin clrscr; repeat   write('n: =');   readln(n); until n in [1..nmax]; repeat   write('m: =');   readln(m); until m in [1..mmax]; writeln('исходный массив: '); randomize; for i: =1 to n do begin   for j: =1 to m do   begin   a[i,j]: =random(10)-3;   write(a[i,j]: 5);   b[i,j]: =a[i,j]*a[i,j]*a[i,j];   end; writeln; end; writeln('результирующий массив: '); for i: =1 to n do begin   for j: =1 to m do   begin   write(b[i,j]: 5);   end; writeln; end; readkey end.
Lesya

ЧТО ТАКОЕ .JPG ФАЙЛ?

JPG файлы классифицируются как файлы растровых изображений, и .jpg формат файла осуществляется для хранения цифровых фотографий и изображений с поддержкой 24-битного цвета. Это делает JPG формат файла стандартный по умолчанию для цифровых производителей камер и профессиональных фотографов. Из-за характеристики сжатия, интегрированных в содержания изображения этих файлов JPG, его размер существенно уменьшается для оптимальной портативности. Это означает, что пользователи могут легко обмениваться цифровыми фотографиями и любимые изображения, сохраняя его в .jpg формате и передачи его через Интернет или по электронной почте. Из-за своего небольшого размера, большие коллекции этих JPG изображения могут быть сохранены во внешних устройствах хранения данных и оптических носителей. Многие приложения сторонних интегрированы с набором функций для редактирования этих JPG изображения

byfetvostochniy

ответ на 1 задачу

Алгоритм выглядит таким образом:

ввести x, y;

если x>y то

s:=(x*y)*2;

иначе

s:=(x+y)/2;

вывод s

конец. (блок-схема прилагается в скриншоте 1)

На паскале выглядит примерно так:

var

x, y, s:real;

begin

readln(x,y);

if x>y then

s:=(x*y)*2;

else

s:=(x+y)/2;

writeln(s:2:2);

end.

ответ на 2 задачу

Тут идентичный алгоритм: вводим 2 переменные x, y, далее создаем условие и возводим в модуль... (скриншот 2 с блок-схемой)

ответ на 3 задачу

Тут тоже.. в условии указываешь просто a<b<c, если условие верно, то выводишь "Верно", иначе "Не верно".

На паскале выглядит примерно так:

var

a, b, c:integer; {если число вещественное}

begin

readln(a, b, c);  

if (a<b<c) then

writeln("Верно");

else

writeln("Неверно");

end.

ответ на 4 задачу

 На паскале:

var

a, b, c, max:integer;

begin

max:=0;

readln(a,b,c);

if max<a then

max:=a;

if max<b then

max:=b;

if max<c then

max:=c;

writeln(max);

end.

 ответ на 5 вопрос

На паскале:

Var

a,b,c:integer;

begin

readln(a,b,c);

if (a<0) then

a:=a*a;

writeln(a);

if (b<0) then

b:=b*b;

writeln(b);

if (c<0) then

c:=c*c;

writeln(c);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу увеличивающую каждый элемент матрицы (n, m) в 3 раза и сохраняющую результат в виде второй матрицы
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ksenia15-79
Oksana-Kirakosyan1301
Акимцева27
vallzh8328
Shevtsov1818
vettime625
puchkovajulia
nunabat457
Natalya1895
reception
Blekjek730
e-s-i-k
alex091177443
marinakmaa86
germanleon