Arsen0708
?>

Написать программу генерирующую и выводящую на экран стозначное целое число.определить делится ли данное стозначное число на 3 или 9

Информатика

Ответы

kulinarprotv

program zadacha;

var x: integer;

begin

  randomize;

  x: =random(9999999999999999999999999999999999999999999999999999999999999999999999999999999999999999999999999999)+1000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000;

  if (x mod 3=0) then begin

    if (x mod 9=0) then writeln('делится на 3 и на 9);

  end;

  if (x mod 3=0) then begin

    if (x mod 9> 0) then writeln('делится только на 3);

  end;

  if (x mod 9=0) then begin

    if(x mod 3> 0) then writeln('делится только на 9);

  end;  

end.

 

 

p.s. вы уверены, что стозначное число?

Наталья Юрьевич1228

Объяснение:

Диало́говое окно́ (англ. dialog box) в графическом пользовательском интерфейсе — специальный элемент интерфейса, окно, предназначенное для вывода информации и (или) получения ответа от пользователя. Получил своё название потому, что осуществляет двустороннее взаимодействие компьютер-пользователь («диалог»): сообщая пользователю что-то и ожидая от него ответа.

Диалоговые окна подразделяются на модальные и немодальные, в зависимости от того, блокируют ли они возможность взаимодействия пользователя с приложением (или системой в целом) до тех пор, пока не получат от него ответ.

dearmaria
#include < iostream> #include < stdio.h> using namespace std; int main(){     int y;     cin> > y;     y=y%12;     switch (y){             case 4: {cout< < "mouse"; break; }             case 5: {cout< < "bull"; break; }             case 6: {cout< < "tiger"; break; }             case 7: {cout< < "rabbit"; break; }             case 8: {cout< < "dragon"; break; }             case 9: {cout< < "snake"; break; }             case 10: {cout< < "horse"; break; }             case 11: {cout< < "goat"; break; }             case 0: {cout< < "monkey"; break; }             case 1: {cout< < "cock"; break; }             case 2: {cout< < "dog"; break; }             case 3: {cout< < "pig"; break; }             }     cin.get();     cin.get();     return 0; }

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу генерирующую и выводящую на экран стозначное целое число.определить делится ли данное стозначное число на 3 или 9
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Snimshchikov465
fucingprinces30
JisesLove19955
Anna Artem
Vitalevich
Владимирович_Намик59
konstantin0112
Vs1377
ikuvila5484
Шмидт Ирина
andr77716
ilyagenius
hr2251
kabinet17
Panei