hristos1212
?>

Составить программу, которая подсчитывает для каждого столбца массива а[1..5, 1..6] сумму значений элементов и формирует из полученных сумм одномерный массив b[1..6].

Информатика

Ответы

iservice38

программа на паскале:

program a1;

var i, j : integer;

      s : real;

      a: array [1..5, 1..6] of real;

      b: array [1..6] of real;

begin

  for i: =1 to 5 do

    for j: =1 to 6 do

        readln(a[i,j]);

  for j: =1 to 6 do

    begin

        s: =0;

        for : =1 to 5 do

            s: =s+a[i,j];

        b[j]: =s

    end;

  write ('полученный массив в: ');

  for j: =1 to d do

    write(b[j]);

  readln

end. 

ivstigres65

Відповідь:

#include <iostream>

using namespace std;

void sortmaxtomin(int *arr){

for(int i = 0; i < 7;i++){

 for(int j = 0; j < 6; j++){

  if(arr[i] > arr[j]){

   swap(arr[i], arr[j]);

  }

 }

}

}

void sortmintomax(int *arr){

for(int i = 0; i < 7;i++){

 for(int j = 0; j < 6; j++){

  if(arr[i] < arr[j]){

   swap(arr[i], arr[j]);

  }

 }

}

}

void printarr(int *arr){

for(int i = 0; i < 7; i++){

 cout << arr[i] << " ";

}

}

int main(){

setlocale(LC_ALL , "Rus");

int A[] = {20,110,40,775,95,145,1100};

cout << "Массив: ";

printarr(A);

cout << "\nСортировка по убыванию: ";

sortmaxtomin(A);

printarr(A);

cout << "\nСортировка по возрастанию: ";

sortmintomax(A);

printarr(A);

return 0;

}

Kulikovvl9

Объяснение:

Для нахождения суммы столбца данных нужно использовать функцию СУММ указав в качестве аргумента диапазон данных которые нужно просуммировать. Например для нахождения суммы всех значений от ячейки А1 до ячейки А100 формула будет выглядеть так:

=СУММ(А1:А100)

Для нахождения суммы квадратов используется функция СУММКВ которая возводит в квадрат свои аргументы и находит их сумму. Например:

=СУММКВ(4; 5) найдет квадрат 4 (это 16), найдет квадрат 5 (это 25) и вычислит их сумму 16+25=41

Для нахождения суммы произведений используется функция СУММПРОИЗВ в качестве аргументов которой указываются диапазоны содержащие числа

Например:

=СУММПРОИЗВ(A3:A5;B3:B5) найдет произведение ячеек А3*B3, A4*B4, A5*B5 и затем вычислит их сумму.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, которая подсчитывает для каждого столбца массива а[1..5, 1..6] сумму значений элементов и формирует из полученных сумм одномерный массив b[1..6].
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

klykovav672
kononova_Pavel689
ver2bit29
Андрей
optikmir
Mamikin
ruslanriad10
boldyrevanastia22
pak1998378
papushinrv4985
aksmobile
Alexander2035
TatianaSeliverstova64
Yevgenevich_Chipura-Nikolaeva
pucha5261