{допустим ,что масив будет вводитса с клавиатуры число символов 10 тип-integer}
program mas;
var m: array [1..10] of integer;
i,o,kp,pp,oo,a,b,s: integer;
begin
writeln ('vvedit masiv');
for i: =1 to 10 do begin
readln (m[i]); end;
o: =0;
for i: =1 to 10 do begin
if m[i]=0 then o: =o+1; end;
kp: =0
for i: =1 to 10 do begin
if m[i] div 5=5 then kp: =kp+1; end;
pp: =0;
for i: =1 to 5 do begin
pp: =pp+m[i]; end;
oo: =0;
for i: =1 to 10 do begin
if m[i]=0 then oo: =oo+1; end;
writeln ('vvedit a i b');
readln (a,b);
s: =0;
for i: =a to b do begin
s: =s+m[i]; end;
writeln ('kolichestvo 0 - ',o);
writeln ('suma kratna 5- ',kp);
writeln ('suma pervix 5- ',pp);
if oo=2 then writeln ('virno v masivi dva nuli') else
writeln ('v masive ne 2 nuli');
writeln ('suma ot a do b= ',s);
end.
{p.s. я не проверял в паскале если будут з нею проблемы то обращяйся}
{p.p.s. обрати внимание на разницу о и 0}
Поделитесь своими знаниями, ответьте на вопрос:
Решить в паскале с использованием цикла с ! составить программу запроса пароля пока не будет введён пароль верно. в программе предусмотреть счётчик неправильных вводов пароля.
const
n = 20;
var
a, b: array[1..n] of integer;
i, k: integer;
begin
randomize;
for i : = 1 to n do
begin
a[i] : = 10 + random(90);
write(a[i]: 3);
end;
writeln;
k : = 1;
for i : = 1 to n - 1 do
begin
if a[i] < a[n] then
begin
b[k] :
= a[i];
write(b[k]: 3);
k += 1
end;
end;
end.