mnkrasnova
?>

Написать программу, которая считает и выводит на экран сумму всех целых чисел из промежутка [a, b]. числа a и b задает пользователь. программу реализовать с трех циклических алгоритмов: 1) цикл со счетчиком for 2) цикл с предусловием while 3) цикл с постусловием repeat в программе предусмотреть ситуацию, когда пользователь вводит значение b ‹ a пример 1: пользователь вводит числа a=5, b=10. сумма чисел: 5+6+7+8+9+10. вывод на экран: 45 пример 2: пользователь вводит числа a=7, b=4. сумма чисел: 4+5+6+7. вывод на экран: 22 пример 3: пользователь вводит числа a=5, b=5. сумма чисел: 5. вывод на экран: 5

Информатика

Ответы

galiyamart6671
Program cikle; uses crt; var a,b,i,k: integer; begin clrscr; write('введите а: '); readln(a); write('введите b: '); readln(b); if a> b then begin i: =a; a: =b; b: =i end; {} {1 способ реализации - цикл for} k: =0; for i: =a to и do k: =k+i; {} {2 способ реализации - цикл с предусловием while} k: =0; while a< =b do begin k: =k+a; a: =a+1 end; {} {3 способ - цикл с постусловием repeat} k: =0; repeat k: =k+a; a: =a+1; until a> b; {} {окончание программы одинаковое для всех способов} writeln('сумма элементов в интервале [a; b] равна ', k) readln end.
Zebra198383
Program yeah; const n=15; const m=15; var a: array [1..n,1..m] of integer; i,j,b,c,x,y: integer; beginrandomize; write('матрица: '); writeln; for i: =1 to n do begin    for j: =1 to m do begina[i,j]: =random(100); write(a[i,j]: 3); end; writeln; end; c: =1; while c< 16 do beginfor i: =1 to n do begin    for j: =1 to m do beginb: =a[1,c]; end; end; x: =x+b; c: =c+1; end; writeln('сумма первой строчки: ',x); c: =1; while c< 16 do beginfor i: =1 to n do begin    for j: =1 to m do beginb: =a[15,c]; end; end; y: =y+b; c: =c+1; end; writeln('сумма последней строчки: ',y); x: =x+y; writeln('общая сумма: ',x); end.
tkozina
// pascalabc.net 3.1, сборка 1239 от 08.05.2016 begin   var p: =biginteger(1);   for var i: =1 to 5 do p*=readlnstring('введите число: ').tobiginteger;   writeln('произведение равно ',p) end. тестовое решение введите число: 54636345465436 введите число: 3453546454645356 введите число: 645234545376678457 введите число: 96776437463 введите число: 123142325624656998887909978986675622 произведение равно 1450913554189850838728716778863079022580143228594634478735461839146946566264784968043421600032

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая считает и выводит на экран сумму всех целых чисел из промежутка [a, b]. числа a и b задает пользователь. программу реализовать с трех циклических алгоритмов: 1) цикл со счетчиком for 2) цикл с предусловием while 3) цикл с постусловием repeat в программе предусмотреть ситуацию, когда пользователь вводит значение b ‹ a пример 1: пользователь вводит числа a=5, b=10. сумма чисел: 5+6+7+8+9+10. вывод на экран: 45 пример 2: пользователь вводит числа a=7, b=4. сумма чисел: 4+5+6+7. вывод на экран: 22 пример 3: пользователь вводит числа a=5, b=5. сумма чисел: 5. вывод на экран: 5
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

secretary
Stasyadoma
anikamalish
Попов1946
IAleksandrovna45
keti0290103
rsd737
ilds88
shangina1997507
smalltalkcoffee5
kap393
baulinanatalia7201
rusmoney92
Neveselova
mariy-inkina8