targovich
?>

Синформатикой, дан текст. слова в тексте разделены одним или несколькими пробелами. написать программу, выводящую все слова в алфавитном порядке.

Информатика

Ответы

Людмила902
Var s,s1: string;     a: array[1..100] of string;       n,i,j,k: byte; begin writeln('введите текст из слов, разделенных пробелами'); readln(s); s: =' '+s+' '; n: =length(s); i: =2; k: =0; while i< =n do if (s[i]< > ' ')and (s[i-1]=' ') then begin  k: =k+1;   j: =i;   s1: ='';     while (j< =n) and (s[j]< > ' ') do     begin    s1: =s1+s[j];     j: =j+1;     end;   a[k]: =s1;   i: =i+length(s1);   end else i: =i+1; for i: =1 to k-1 do for j: =i+1 to k do if a[i]> a[j] then  begin  s1: =a[i];     a[i]: =a[j];   a[j]: =s1   end; writeln('слова текста в алфавитном порядке: '); for i: =1 to k do writeln(a[i]); end.
frsergeysavenok
Const n = 5; m = 6; var    a: array[1..n, 1..m] of integer;   c: array[1..n] of integer;   i, j, mx, mn: integer;     begin   randomize;   writeln('исходная матрица');   mn : = 1;   for i : = 1 to n do begin     mx : = -(maxint-1);     for j : = 1 to m do begin       // случайное число от -500 до 500       a[i, j] : = random(1001) - 500;       // выводим       write(a[i, j]: 5, ' ');       // ищем макс в строке       if mx < a[i,j] then mx : = a[i,j];     end;           c[i] : = mx; // макс в строке           // поиск минимума     if c[mn] > c[i] then mn : = i;     writeln;   end;       writeln ('вектор с');   for i : = 1 to n do      write(c[i]: 5, ' ');         writeln(#13, #10, 'минимальный элемент: ');   writeln('c[', mn, '] = ', c[mn]); end.
slipu817838
#include < iostream> #include < vector> int main() {     int b[5][6];     std: : vector< int> vec;     for(int i = 0; i < 5; ++i)         for(int j = 0; j < 6; ++j)             std: : cin > > b[i][j];     for(int i = 0; i < 5; ++i)     {         int max = b[i][0];         for(int j = 1; j < 6; ++j)             if (max < b[i][j])                 max = b[i][j];         vec.push_back(max);     }     int min = vec[0];     int number = 0;     for(int i = 1; i < 5; ++i)            if (min > vec[i])         {             min = vec[i];             number = i;         }     std: : cout < < number; }

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Синформатикой, дан текст. слова в тексте разделены одним или несколькими пробелами. написать программу, выводящую все слова в алфавитном порядке.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

grekova5
benonika
Краева
IrinaSolodukhina1495
Антон
Eduard Popik
elenaneretina
krisrespect2
abroskin2002
spec-nt
Пономаренко
magazin3000
trast45
shakovaea
shumilovs7252
▲