firsova5911
?>

Дано натуральное число n. составьте программу, которая определяет входит ли цифра 6 в запись числа n^2.

Информатика

Ответы

amaraks67
#include < iostream> #include < cmath> using namespace std; int main() {       int n=0;       cin> > n;       long long nn=pow(n,2);       cout< < nn< < endl;       while(nn! =0)       {             if(nn%10==6){cout< < "da"; break; }             nn/=10;       }       if(nn==0)cout< < "net";       return 0; }
Ярослав
Const       e = 0.000001; var       i, f, f1, thn, t: integer;       s, s1: real; begin       i : = 0;       f1 : = 1;       f : = 2;       thn : = -1;       s : = 1;       s1 : = 0;       repeat               i : = i + 1;               s1 : = s;               thn : = thn * -3;               s : = s + 2 * i / f / thn;               writeln(2 * i, ' ', f, ' ', thn, ' ', s);               t : = f1;               f1 : = f;               f : = f + t       until abs(abs(s1) - abs(s)) < e;       writeln(s); end.
nchorich55
Const       n = 30; var       i: integer;       a, d: array[1..n]of integer; begin       for i : = 1 to n do       begin               d[i] : = random(100);               if i < = 10 then                       a[i] : = d[i] + i               else                       a[i] : = d[i] - i;               write(d[i]: 4, ' ');       end;             writeln();       for i : = 1 to n do               write(a[i]: 4, ' '); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дано натуральное число n. составьте программу, которая определяет входит ли цифра 6 в запись числа n^2.
Ваше имя (никнейм)*
Email*
Комментарий*