studiojanara
?>

Это важно для меня и сложно, завтра зачет и будут такие , мне, , совершенно не смыслю в этом! к зачету по разделу: "основы программирования на паскале" 1. составьте программу для решения следующей : найти длину окружности l=2*п(пи)*r и площадь круга s=п(пи)*rв квадрате заданного радиуса r. в качестве значения п(пи) использовать 3, 14. 2. составить программу для решения : возраст коли- х лет, миши- y лет. найти их средний возраст, а также определить, насколько отличается возраст каждого мальчика от среднего значения. 3. составьте программу для решения следующей : дано целое число. если оно является положительным, то прибавить к нему 1; если отрицательным, то вычесть из него 2; если нулевым, то заменить его на 10. вывести полученное число. 4. составьте программу для решения следующей : даны три числа. найти сумму двух наибольших из них. 5. составить программу для решения следующей : напечатать все целые числа от а до в в "столбик". 6. составить программу для нахождения суммы: s= 1+ 1/2+1/3+/n 7. составить программу для решения следующей : все четные положительные элементы массива из 20 целых случайных чисел в интервале [-15, 25] уменьшить вдвое, все нечетные положительные увеличить на 2, а у всех остальных поменять знак.

Информатика

Ответы

o-pavlova-8635
Не корректно объяснили, но если правильно вас понял:   program g;   var n, z, m, p: integer;   begin      z: =0;   p: =0;     m: =0;     writeln('введите число n. число 9999 завершает цикл.');     readln(n);     while n< > 9999 do      begin        if n=0 then inc(z);           else if n> 0 then inc(p);           else inc(m);         writeln('введите число');         readln(n);       end;     writeln('было введено ', z, ' нулей.');     writeln('было введено ', p, ' положительных чисел.');     writeln('было введено ', m, ' отрицательных чисел.');       readln;   end.
Feyruz90
Program g; uses crt; var count, num, ch: integer; begin    clrscr;     writeln('год високосный? 1 - да, 0 - нет');     readln(ch);     if ch=1 then      begin        writeln('введите номер месяца');       readln(num);         сase num of          1, 3, 5, 7, 8, 10, 12: writeln('в месяце 31 день.');         4, 6, 9, 11: writeln('в месяце 30 дней.');         2: writeln('в месяце 29 дней');         else writeln('некорректный ввод данных')      end;     end      else if ch=0   then      begin        writeln('введите номер месяца');         readln(num);     сase num of            1, 3, 5, 7, 8, 10, 12: writeln('в месяце 31 день.');           4, 6, 9, 11: writeln('в месяце 30 дней.');           2: writeln('в месяце 28 дней');         else writeln('некорректный ввод данных')        end;       end    else writeln('некорректный ввод данных'); readln;   end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Это важно для меня и сложно, завтра зачет и будут такие , мне, , совершенно не смыслю в этом! к зачету по разделу: "основы программирования на паскале" 1. составьте программу для решения следующей : найти длину окружности l=2*п(пи)*r и площадь круга s=п(пи)*rв квадрате заданного радиуса r. в качестве значения п(пи) использовать 3, 14. 2. составить программу для решения : возраст коли- х лет, миши- y лет. найти их средний возраст, а также определить, насколько отличается возраст каждого мальчика от среднего значения. 3. составьте программу для решения следующей : дано целое число. если оно является положительным, то прибавить к нему 1; если отрицательным, то вычесть из него 2; если нулевым, то заменить его на 10. вывести полученное число. 4. составьте программу для решения следующей : даны три числа. найти сумму двух наибольших из них. 5. составить программу для решения следующей : напечатать все целые числа от а до в в "столбик". 6. составить программу для нахождения суммы: s= 1+ 1/2+1/3+/n 7. составить программу для решения следующей : все четные положительные элементы массива из 20 целых случайных чисел в интервале [-15, 25] уменьшить вдвое, все нечетные положительные увеличить на 2, а у всех остальных поменять знак.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

orantus3
Gennadievna bessonov
helena-belozerova
Batrakova-Anna
qwqwweqw3
Pokupatel
Bella Sergei
Kushchenko-Monashev
Olesya-elena1525
R7981827791127
saljagindima
olegmgu1
Dubovitskayae
ирина_Андреевич1634
Юлия1972