paninsv
?>

№2. составить программу для решения : задайте целое число; определите, кратно ли оно 10.

Информатика

Ответы

Владимировна Екатерина
Program pascal; var n : longint; begin     writeln ('введите число: ');       read(n);     if n> 0 then      if n mod 10 =0 then writeln('число ',n,' кратное 10')     else     writeln('число ',n,' не кратное 10'); end.
okykovtun31
Program zadbl; uses crt; var  a,b,c,i,s: integer; m: array[1..30] of integer; begin  s: =-1;   for i: =1 to 30 do   begin  m[i]: =random(100);   write(m[i]: 3);   end;   for i: =1 to 28 do   begin    if m[i]+m[i+1]+m[i+2]> s then   begin    a: =m[i];     b: =m[i+1];     c: =m[i+2];     s: =a+b+c;     end;     end;     writeln('   a   b   c');     write(a: 3);     write(b: 3);     write(c: 3);     readln; end.
ccc712835
Program arrayminvalueswapfirst; var  numbers: array [1..10] of integer;   maxvalindex: integer; begin  write('исходный массив: ');   for var i: integer : = 1 to 10 do  begin    numbers[i] : = random(11);     write(numbers[i]);     if i < 10 then      write(', ');   end;   var minval: integer : = -1; // сюда записываем рекорд по значению  for var i: integer : = 1 to 10 do    if (numbers[i] > minval) then    begin      minval : = numbers[i];       maxvalindex : = i;     end;   writeln();   writeln('индекс максимального: ', maxvalindex);   var buf: integer : = numbers[1];   numbers[1] : = minval;   numbers[maxvalindex] : = buf;   write('результат      : ');   for var i: integer : = 1 to 10 do  begin    write(numbers[i]);     if i < 10 then      write(', ');   end; end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

№2. составить программу для решения : задайте целое число; определите, кратно ли оно 10.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Павловна1750
klimovala2
Кирьяков-Крикунов
dumpler
udalova-yelena
topsalon
BrezhnevaKoidula
cherry-sweet871435
lovely138887
Advantage9111
ivanpetrovichru1801
АнжелаВасильевич
Vasilisan
Yurevna
aprelevka