Anatolevich1506
?>

Паскаль авс , при функции trunc() в паскале можно реализовать операции целочисленного деления и взятия остатка от деления. например: целочисленное деление - trunc(491/240) - результатом будет 2; остаток от деления - 491-240*trunc(491/240) - результатом будет 11. используя функцию напишите программу, считающую сдачу в денежной системе (в этой денежной системе 1 фунт стерлингов равен 20 шиллингам, а 1 шиллинг равен 12 пенсам напишите программу, в которой в трёх константах хранится стоимость товара. одна константа - фунты (целое значение больше нуля), вторая - шиллинги (значение от 0 до 19), третья - пенсы (значение от 0 до 11). ещё в трёх таких же константах хранится плата покупателя. используя одну целочисленную переменную, программа должна сосчитать и вывести на экран сдачу в фунтах, шиллингах и пенсах. не использовать условный оператор программа должна быть написана на паскале авс

Информатика

Ответы

ГалинаРайгородская
Водном фунте 20*12=240 пенсов. стоимость товара: f1 - фунты, s1 - шиллинги, p1 - пенсы плата покупателя: f2 - фунты, s2 - шиллинги, р2 - пенсы х - сдача в пенсах const   f1=11;   s1=5;   p1=3;   f2=12;   s2=10;   p2=0; var     x: integer; begin  x: =f2*240+s2*12+p2-f1*240-s1*12-p1;   writeln('сдача: ');   writeln('фунтов ',trunc(x/240));   x: =x-240*trunc(x/240);   writeln('шиллингов ',trunc(x/12));   x: =x-12*trunc(x/12);   writeln('пенсов ',x); end.
suhovaab
Var       a: integer;       s: longint; begin       s : = 0;       readln(a);             while a < > 0 do       begin               if (a mod 2 = 0) and (a > 5) then                       s : = s + a;               readln(a);       end;             writeln(s); end.
mnn99
Program n_5; var     a, b, c: real; procedure n_1; begin   if ((a< b) and (a> c)) or ((a< c) and (a> b)) then   write (a)   else   if ((b< a) and (b> c)) or ((b< c) and (b> a)) then     write (b)   else     if ((c< a) and (c< b)) or ((c< b) and (c> a)) then     write (c); end; begin   writeln ('введите три трёхзначных числа');   readln (a);   readln (b);   readln (c);   if ((a > = 100) and (a < = 999) and (a < > b) and (a < > c)) and ((b > = 100) and (b < = 999) and (b < > a) and (b < > c)) and ((c > = 100) and (c < = 999) and (c < > a) and (c < > b)) then n_1   else   write ('error'); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Паскаль авс , при функции trunc() в паскале можно реализовать операции целочисленного деления и взятия остатка от деления. например: целочисленное деление - trunc(491/240) - результатом будет 2; остаток от деления - 491-240*trunc(491/240) - результатом будет 11. используя функцию напишите программу, считающую сдачу в денежной системе (в этой денежной системе 1 фунт стерлингов равен 20 шиллингам, а 1 шиллинг равен 12 пенсам напишите программу, в которой в трёх константах хранится стоимость товара. одна константа - фунты (целое значение больше нуля), вторая - шиллинги (значение от 0 до 19), третья - пенсы (значение от 0 до 11). ещё в трёх таких же константах хранится плата покупателя. используя одну целочисленную переменную, программа должна сосчитать и вывести на экран сдачу в фунтах, шиллингах и пенсах. не использовать условный оператор программа должна быть написана на паскале авс
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Александровна1244
abuzik
Владимир
pastore
Валентина980
mnogoz
utburt
Khlistova1488
Marianna45
NatalyaAlekseevich1644
dimaproh
Cannabikh
vodoleytatyana
sashakrav
Alsergus7811