Владимирович_Слабый
?>

Составьте программу для решения следующей . введите с клавиатуры два числа: а и в. если числа не равны, то замените каждое из них большим и выведите результаты на экран. если они равны, то найдите и выведите удвоенную сумму этих чисел.

Информатика

Ответы

annashersheva
  var       var         a,b: integer;   begin   readln (a,b); if a = b then   writeln (4*a)   else     writeln(a+1,' ',b+2); end.
selena77

Скопировать код в Dev C++ и запустить в компиляторном окне будут выведены значения.

Объяснение:

Dev C++

1) #include <iostream>

#include <stdio.h>

#include <stdlib.h>

#include <math.h>

int main(int argc, char** argv) {

int x = 5, y = 10;

while(y<=10){

 if (x <= y){

  x = x + 1;

  y = y - 1;

 }

 else {

  x = x - 5;

  y = y + 5;

 }  

}

printf("X = %d", x);

printf("\nY = %d", y);

return 0;

}

2) #include <iostream>

#include <stdio.h>

#include <stdlib.h>

#include <math.h>

int main(int argc, char** argv) {

int a = 2, b = 0;

while (a != 7){

 a = a + 1;

 b = b + a;

}

printf("a = %d", a);

printf("\nb = %d", b);

return 0;

}

3) #include <iostream>

#include <stdio.h>

#include <stdlib.h>

#include <math.h>

int main(int argc, char** argv) {

int a = 56, b = 77;

while (a != b){

 if (a > b){

  a = a - b;

 }

 else {

  b = b - a;

 }

}

printf("a = %d", a);

printf("\nb = %d", b);

return 0;

}

4) #include <iostream>

#include <stdio.h>

#include <stdlib.h>

#include <math.h>

int main(int argc, char** argv) {

int a = 6, b = 0;

while (a!=2){

 b = b + a;

 a = a - 1;

}

printf("a = %d", a);

printf("\nb = %d", b);

return 0;

}

5) #include <iostream>

#include <stdio.h>

#include <stdlib.h>

#include <math.h>

int main(int argc, char** argv) {

int a = 1, b = 0;

while (a != 1024){

 b = b + a;

 a = a * 2;

}

printf("a = %d", a);

printf("\nb = %d", b);

return 0;

}

sergeevna

Скопировать код в Dev C++ и в компиляторном окне выведутся числа в результате работы программы

Объяснение:

1) #include <iostream>

#include <stdio.h>

#include <stdlib.h>

#include <math.h>

int main(int argc, char** argv) {

int a = 1, b = 3;

b = b - 1;

a = a = b;

while (b > 0){

 b = b - 1;

 a = a - b;

}

while (a <= 8){

 a = a + 2;

 b = b - 3;

}

printf("a = %d", a);

printf("\nb = %d", b);

return 0;

}

2) #include <iostream>

#include <stdio.h>

#include <stdlib.h>

#include <math.h>

int main(int argc, char** argv) {

int a = 1, b = 11;

while (a <= 4){

 a = a + 1;

 b = b - 2;

}

b = b - 1;

a = a + b;

while (b > 0){

 b = b - 1;

 a = a + b;

}

printf("a = %d", a);

printf("\nb = %d", b);

return 0;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу для решения следующей . введите с клавиатуры два числа: а и в. если числа не равны, то замените каждое из них большим и выведите результаты на экран. если они равны, то найдите и выведите удвоенную сумму этих чисел.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Цветкова
pavlovm8316
museumuzl
mskatrinmadness
родичева1812
s-shulga
alexandr25901
info2
Рафаэль633
Ka-tja78
kosbart28
appmicom
galereyaas1568
kurlasku
eobmankina