elenachuxina804
?>

Pascal авс - написать программу, ! для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. · если все числа не превышают 30, то выведите их удвоенное произведение. · если последнее число четно, то выведите произведение первых двух чисел, уменьшенное в десять раз. · если выполняются одновременно два перечисленных выше условия, то выведите эти числа без изменения. · иначе, выведите разность первого и последнего чисел. составьте соответствующие отладочные примеры и проверьте работу каждой программы. заранее .

Информатика

Ответы

Struev730
Var    a,b,c,d,p : integer;     r : real; begin readln (a,b,c,d); p : = 0; if (a< =30) and (b< =30) and (c< =30)  and (d< =30) then       begin      p : = p +1;         r: = a*b*c*d*2;       end; if d mod 2 = 0 then     begin      r : = a*b/10;       p : = p + 1;     end ; case p of 0 : writeln (a-d);   //как я понял иначе (все условия не выполняются) 1 : writeln (r); 2 : writeln (a,' ',b,' ',c,' ',d);   end; end.
Nazart44446

Видеока́рта (также видеоада́птер, графический ада́птер, графи́ческая пла́та, графи́ческая ка́рта, графи́ческий ускори́тель) – устройство, преобразующее графический образ, хранящийся как содержимое памяти компьютера (или самого адаптера), в форму, пригодную для дальнейшего вывода на экран монитора. Первые мониторы, построенные на электронно-лучевых трубках, работали по телевизионному принципу сканирования экрана электронным лучом, и для отображения требовался видеосигнал, генерируемый видеокартой.

gbg231940
Все программы - список всех установленных программ, приложений и игр окно поиска - найти в компьютере любую информацию или файл, соответствующий параметрам поиска user - вся информация о пользователе компьютера и его файлах, программах и т.д. документы - папка в которой вы можете хранить любые документы, например из office microsoft word с разрешение .docx изображения - папка, в которой хранятся стандартные изображения windows или образцы изображений, сюда же можно помещать свои фотографии, например с разрешением .jpg и .jpeg музыка - папка, в которой хранится стандартная музыка windows, сюда же можно помещать свою музыку, например файлы с расширением .mp3 компьютер (или мой компьютер) - окно, в котором можно увидеть информацию о дисках и внешних носителях, используется для перехода к каким-либо нужным файлам или получении информации о жестких дисках и внешних носителях панель - эта панель включает в себя все необходимые средства для компьютером. например раздел "экран" отвечает за разрешение и другие настройки экрана монитора устройства и принтеры - один из разделов "панели ", отвечающий за и настройку принтеров и всех подключенных к компьютеру устройств, также в этом разделе можно просмотреть информацию об устройствах и принтерах программы по умолчанию - список всех заводских программ, установленных вместе c windows, а также их и настройка справка и поддержка - раздел "панели ", который сможет ответить на какие-либо вопросы, возникшие при работе с компьютером

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Pascal авс - написать программу, ! для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. · если все числа не превышают 30, то выведите их удвоенное произведение. · если последнее число четно, то выведите произведение первых двух чисел, уменьшенное в десять раз. · если выполняются одновременно два перечисленных выше условия, то выведите эти числа без изменения. · иначе, выведите разность первого и последнего чисел. составьте соответствующие отладочные примеры и проверьте работу каждой программы. заранее .
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

nataliaterekhovasinger2
yurkovam-037
chumakanna17
Misyura_Viktoriya1683
ivanovmk1977
skvorec3424
Руслан1360
okasnab
saljagindima
Anastasiamoscow80
Новицкий1107
Борисович409
reinish23
narkimry134
allaraygor
▲