vitbond12
?>

Написать подпрограмму, вычисляющую натуральную степень числа. паскаль написать программу на компьютере и проверить правильность работы вашей процедуры/функции, в этом случае в основной программе должны быть реализованы ввод исходных данных и вызов процедуры/функции.

Информатика

Ответы

vikanikita
Используем достаточно хорошо известный "индийский алгоритм" возведения в степень. я не буду здесь его приводить из-за достаточно большого объема рассуждений; все легко находится в интернет по фразе "индийский алгоритм возведения в степень". function power(x: double; n: integer): double; var   p: double;   flag: boolean; begin   p : = 1; flag : = true;   while flag do   begin       if odd(n) then p : = p * x;       n : = n div 2;       if n > 0 then x : = x * x else flag : = false   end;   power : = p end; var   x: double;   n: integer; begin   writeln('введите число и натуральную степень, в которую его надо возвести');   readln(x, n);   writeln('результат: ', power(x, n)) end. тестовое решение: введите число и натуральную степень, в которую его надо возвести 3.6 11 результат: 1316217.03842267 точный результат равен 1316217.03842267136.
Александрович Василий
Var i,k,n,m: integer; begin   write('n = '); readln(n);   m: =round(sqrt(n));   i: =2; k: =1;   repeat     if (n mod i=0) then     begin       if i< > k then        begin         write(i,' ');         k: =i;       end;         n: =n div i;       m: =round(sqrt(n));       i: =1;     end;     i: =i+1;   until i> m;   if k< > n then writeln(n); end.     n = 43021568 2 163 1031n = 625 5  n = 189756328 2 67 354023
Ивлев1508
Var     a: array[1..15] of integer;     i, sum, count: integer; begin     for i: =1 to 15 do       readln(a[i]);     sum : = 0; count : = 0;     for i: =1 to 15 do       if a[i] > 0 then       begin           sum : = sum + a[i];           inc(count);       end;     writeln(sum, ' ', count); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать подпрограмму, вычисляющую натуральную степень числа. паскаль написать программу на компьютере и проверить правильность работы вашей процедуры/функции, в этом случае в основной программе должны быть реализованы ввод исходных данных и вызов процедуры/функции.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

gusrva3001
germanleon
marinakmaa86
jaksonj326
notka19746
ganzashop
anovikovsr
Liliya-buc
annakuznetsova841
gladkihvv
Aleksei1463
pbttehnology
teya07
Татьяна902
Railyan