Vasilevna_Utenkova651
?>

Cи написать программу, считывающую с клавиатуры 32-битное беззнаковое число n, числа a и b и выводящую на экран число, равное исходному n, но с установленным битом номер a и снятым битом номер b

Информатика

Ответы

koxhulya61
#include < iostream> using namespace std; int main() {       unsigned int n,a,b;       cin> > n> > a> > b;       n& =1< < a;       n& =(< < b);       cout< < n;       return 0; } что-то в этом духе
Алексей Ксения

var a: string; x: integer; begin write('введите слово: '); readln(a); length(a); if (a[2]='а') or (a[2]='б') or (a[2]='в') or (a[2]='г') or (a[2]='д') then x: =9; if (a[2]='е') or (a[2]='ж') or (a[2]='з') or (a[2]='и') or (a[2]='й') or (a[2]='к') then x: =8; if (a[2]='л') or (a[2]='м') or (a[2]='н') or (a[2]='о') or (a[2]='п') or (a[2]='р') then x: =7; if (a[2]='с') or (a[2]='т') or (a[2]='у') or (a[2]='ф') or (a[2]='х') or (a[2]='ц') then x: =6; if (a[2]='ч') or (a[2]='ш') or (a[2]='щ') or (a[2]='ы') or (a[2]='ъ') or (a[2]='ь') or (a[2]='э') or (a[2]='ю') or (a[2]='я') then x: =5; writeln('перевод: ', x); end.

Komarovsergeysk

1) program task3; var a, ost, k: integer; beginwrite (ввести число a -> '); read (a); k: =0; while a< > 0 do beginost: = a mod 10; if ost mod 2 = 0 then k: =k+1; a : = a div 10end; writeln (k);   end. 

 

2)   эту не знала как исправить, поэтому в основном просто переписала : )

program task4; var a, s, t, i, k: integer; n: real; beginwrite ('введи кол-во дней -> '); readln (a); k: =0; s: =0; for i : = 1 to a dobeginwrite ('введи температуру в   ',i,-ый день'); readln(t); if t> 0 thenbegink: =k+1; s: =s+t; end; end; writeln('кол-во дней, в течение которых проводилось наблюдение ', a); writeln('кол-во дней с   t> 0 = ', k); n: =s/k; writeln (средняя температура в дни с   t> 0 ',n)end.

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Cи написать программу, считывающую с клавиатуры 32-битное беззнаковое число n, числа a и b и выводящую на экран число, равное исходному n, но с установленным битом номер a и снятым битом номер b
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

multikbo3049
dianakryukova00
Надья-Олеговна
Vladmouse32506
lokos201272
Анатольевна
evolkova-73
Vladimirovna-Ignatenko1890
Воздвиженская
fruktovahere
Donleksa2016
sotrudnik3
MislitskiiSergei1403
aamer9992680
semenovakotya577