type cl = class a: integer; constructor create(b: integer); procedure setval(b: integer); function getval: integer; procedure sq; end; constructor cl.create(b: integer); begin a : = b; end; procedure cl.setval(b: integer); begin a : = b; end; function cl.getval: integer; begin getval : = a; end; procedure cl.sq; begin if a < 0 then writeln('a ^ 2 = ', a * a) else writeln('error'); end; var obj: cl; a : integer; begin write('a = '); readln(a); obj : = cl.create(a); obj.sq; readln; obj.destroy; end.
var
a,b: integer;
function max(a, b: integer): integer;
begin
if a > = b then
max: =a else max : = b; end;
function min(a, b: integer): integer;
begin
if a < = b then
min : = a else min : = b;
end;
begin
write ('введите число a ');
readln (a);
write ('введите число b ');
readln (b);
writeln(max(a,b)-min(a,b));
end.
Поделитесь своими знаниями, ответьте на вопрос:
Надо составить программу. дана последовательность натуральных чисел а1, а2, аn. создать массив из нечетных чисел этой последовательности если таких нет, выведите сообщение об этом факте. надо