BelozerovaGeller648
?>

Написать программу: в массиве из 10 вводимых с клавиатуры чисел подсчитать количество чисел кратных первому элементу, но не кратных последнему элементу.  ​

Информатика

Ответы

Stroeva19651938

var

    numbers: array[1..10] of integer;

    i, first, last, count, num: integer;

begin

    writeln('введите 10 чисел');

   

    for i : = 1 to 10 do

        readln(numbers[i]);

    first : = numbers[1];

    last : = numbers[10];

   

    for i : = 1 to 10 do begin

        num : = numbers[i];

       

        if (num > = first) and (num mod first = 0) then

            if (num < last) or (num mod last < > 0) then

                count : = count + 1;

    end;

   

    writeln(count);

end.

Evelina Mariya

Объяснение:

Під анімацією розуміють серію зображень, які відтворюються послідовно та імітують рух. Для її створення можна застосовувати програмні технології на зразок Adobe Flash, а також анімовані GIF-файли.

Аудіо (музика, голос, звукові ефекти) — невід’ємна частина багатьох мультимедійних продуктів. Наприклад, голос диктора в навчальних курсах, музичний супровід в іграх, підкасти (цифрові аудіофайли, що поширюються через Інтернет і призначені для відтворення на ПК та медіапрогравачах). Аудіо записують за до мікрофона або MIDI-іпструментів, наприклад MIDI-клавіатури, що імітує клавіатуру фортепіано.

Відео. На відміну від анімації, що складається з окремих зображень, які відтворюються послідовно, відео — це неперервний потік візуальної інформації, який розділяється па окремі кадри під час запису. Коли вони відтворюються з певною частотою (зазвичай ЗО кадрів/с), око сприймає їх як безперервний потік візуальної інформації. Відео отримують за до відеокамери, а розповсюджують за до телебачення, кінофільмів (записаних па носіях) та через Інтернет.

elizabetmaslova3
Var       i, k, n: integer; begin       k : = 0;             for i : = 1 to 10 do       begin               write('введите число');               readln(n);               if n < 0 then k : = k + 1;       end;             writeln(k); end. понимаю так - вводится 10 чисел, посчитать сколько из них отрицательные

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу: в массиве из 10 вводимых с клавиатуры чисел подсчитать количество чисел кратных первому элементу, но не кратных последнему элементу.  ​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Юрий197
васильевич
Александрович833
Mariya-Karaseva
postbox
Matveevanastya0170
Bogataya Vladimir318
Olia72
elyashatdinova
postbox
Валерьевна1601
a-lossev111
Vladimirovna Dmitrieva
Sergei_sergei
Рафаэль633