условие или истинно, если хотя бы одно высказывание истинно.
таблица истинности для условия или:
a или b = с1 1 11 0 10 1 10 0 0приставка не означает истину, если высказывание ложно и ложь, если высказывание истинно (то есть она меняет истину и ложь)
его можно понимать как высказывание "первая буква не гласная"
аннане (первая буква гласная) 0
последняя буква гласная 1
0 или 1 = 1
истина
максимне (первая буква гласная) 1
последняя буква гласная 0
1 или 0 = 1
истина
татьянане (первая буква гласная) 1
последняя буква гласная 1
1 или 1 = 1
истина
егорне (первая буква гласная) 0
последняя буква гласная 0
0 или 0 = 0
ложь
антонне (первая буква гласная) 0
последняя буква гласная 0
0 или 0 = 0
ложь
Поделитесь своими знаниями, ответьте на вопрос:
Гражданин открыл счёт в банке вложив x рублей под y% годовых через сколько лет сумма вклада превысит z рублей напишите программу в чтобы можно было подставить в паскаль
var x,y,z: real;
n: integer;
begin
n: =0;
write('сумма вклада: ');
readln(x);
write('процент головых: ');
readln(y);
write('сумма через n лет: ');
readln(z);
while x< =z do begin
x: =x*(1+y/100);
n: =n+1;
end;
writeln(n);
end.