kononova_Pavel689
?>

На языке программирования pascal, прошу( заранее ) 1) составьте программу, проверяющую, верно ли утверждениечто введенное вами целое число является четным. 2)напишите программу, которая бы запрашивала целое число и распечатывала любое его значение, кроме 13. если заданное число равно 13, вместо него печатается число 77. ; (( если незнаете как решать не занимайте место для ответа

Информатика

Ответы

xalina85
Var   n: integer; begin   write('введите четное число: '); readln(n);   if (n mod 2)=0 then writeln('верно! ')   else writeln('неверно! ') end. var   n: integer; begin   write('введите любое целое: '); readln(n);   if n< > 13 then writeln(n) else writeln(77) end.
arinaunknown6867
По трем сторонам - формула герона. var a,b,c,p: real; begin write('введите стороны: '); readln(a,b,c); p : = (a + b + c) / 2; writeln('площадь равна ', sqrt(p * (p - a) * (p - b) * (p - c)): 9: 4); end. а через основание и высоту (твоя формула): var a,h: real; begin write('введите длину основания и высоты, проведенной к нему: '); readln(a, h); writeln('площадь равна: ', (a * h) / 2: 9: 4); : 9: 4 -- это такой оператор, который выводит число в формате с фиксированной точкой и 4 знаками после запятой.
juliajd
Const   n = 20; var   x: array[1..n] of integer;   i: integer; begin   randomize;   writeln('элементы массива');   i : = n;   for i : = 1 to n do   begin       x[i] : = random(101) - 50;       write(x[i]: 4);   end;   writeln;   while (i > = 1) and (x[i] > = 0) do i : = i - 1;   if i > 0 then       writeln('последний отрицательный элемент x[', i, ']=', x[i])   else       writeln('нет отрицательных элементов') end. тестовое решение: элементы массива     5  -9 -32 -48  33    2 -41  24  31 -31 -48 -24 -17  45 -41 -23  -1  38  45  14 последний отрицательный элемент x[17]=-1

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На языке программирования pascal, прошу( заранее ) 1) составьте программу, проверяющую, верно ли утверждениечто введенное вами целое число является четным. 2)напишите программу, которая бы запрашивала целое число и распечатывала любое его значение, кроме 13. если заданное число равно 13, вместо него печатается число 77. ; (( если незнаете как решать не занимайте место для ответа
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ok-49566
pelagia-kola2658
AlekseiMardanova
molodoychek
miha23727
annarom1306
Lazar
kovalenko262
Busyashaa
irinatikhonov
rosik76
Андреевич-Екатерина1974
Valerevna
АнтонАртем
nash-crimea2019