elenachuxina804
?>

Даны натуральные числа a и b (b> aнаписать программу, выводящую на экран последовательность натуральных чисел от a до b, не включая a и b не могу понять !

Информатика

Ответы

Чиркина999
Program zadanie; var a,b,i: integer; begin   writeln('введите значения a и b, причем b> a (иначе программа не будет исполняться)');   readln(a,b);   for i: =a to b do   if (i> a) and (i< b)  then write(i,','); end.
magichands68

Программа:

#include <bits/stdc++.h>

using namespace std;

int main() {

  int a, b, c, d, n;

  cin >> a >> b >> c >> d >> n;

  if (a > b && a > c && a > d)

      a -= n;

  else if (b > a && b > c && b > d)

      b -= n;

  else if (c > a && c > b && c > d)

      c -= n;

  else d -= n;

  cout << a << " " << b << " " << c << " " << d << endl;

  return 0;

}

chechina6646

Питон не учил (учил си шарп, плюс плюс, и паскаль), но принцип такой:

24/3=8 (нашли значение для цикла)

присваиваем переменной значение 0 (это делается до цикла) (далее эта переменная a), затем создаем цикл в котором и будит все программа (он повторяется 8 раз).

a+=3 или a=a+3, ну это как там у вас в питоне)

это действие повторяется каждый цикл (8 раз)

далее мы заранее созданной переменной ещё до цикла присваиваем значение 1.

Затем мы каждый цикл присваиваем этой переменной значение b=b*2

И потом выводим b на экран вместе с a и подписью "часа".

В паскале это выгядело бы так:

begin

a:=0;

b:=1;

for i:=1 to 8 do

begin

 a:=a+3;

 b:=b*2;

 Writeln (b,"_за_",a,"_часа");

end;

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Даны натуральные числа a и b (b> aнаписать программу, выводящую на экран последовательность натуральных чисел от a до b, не включая a и b не могу понять !
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

marinakovyakhova
Peshkov
Анатольевич
Троцкая-Ивановна
yelena
Goldaram84
Murad Gushcharin
majorovnatalya5
stic1995
energycomplect5914
amarantmetall
hbqhzwtd
Голосова-Лобанов1555
Chikichev456
lazaren-ko