dpodstrel85
?>

Напишите программу , которая вводит число n и определяет является ли число n совершенным. совершенные числа - это те числа, которые равны сумме своих делителей, не включая само число, но включаю единицу

Информатика

Ответы

akopsiroyan
Var n, i, s: integer; begin read(n); s: =0; for i: =1 to n-1 do begin     if n mod i = 0 then s: =s+i; end; if s = n then writeln('sovershennoye') else writeln('ne sovershennoye'); end.
vikabobkova2010
#include< iostream> #include< conio.h> int n; int main() {       std: : cin > > n;       if (n % 2 == 0 & & n > 0)           std: : cout < < "number is even and greater than 0" < < std: : endl;       else if (n % 2 == 1 & & n > 0)           std: : cout < < "number is odd and greater than 0" < < std: : endl;       else if (n < 0)           std: : cout < < "number is negative" < < std: : endl;       getch();       return 0; }
irinatikhonov
Const   bd=['0'..'3']; var   s,wa,wb,w: string;   c: char;   i,n: integer;   bad_a: boolean; begin   writeln('вводите фразу, разделяя слова ровно одним пробелом');   read(s);   s: =s+' ';   n: =length(s); wa: =''; wb: ='';   i: =1; bad_a: =false; w: ='';   while i< =n do begin       repeat           c: =s[i];           if c< > ' ' then begin               bad_a: =bad_a or (c in bd);               w: =w+c;               inc(i)           end           else begin               if not bad_a then wa: =wa+' '+w;               if s[i-1]='я' then wb: =wb+' '+w;               w: =''; bad_a: =false           end       until c=' ';       inc(i);   end;   wa: =copy(wa,2,length(wa)-1);   wb: =copy(wb,2,length(wb)-1);   writeln(wa);   writeln(wb) end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу , которая вводит число n и определяет является ли число n совершенным. совершенные числа - это те числа, которые равны сумме своих делителей, не включая само число, но включаю единицу
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Lapushkin1988
VASILEVNA
gymnazium
zrs-546
Sergei_Olga658
pafanasiew
marinazubcko16729
fmba18
lagutkins
Катерина Телюкин925
gameover98
iivanov54
Anastasiya
Aleks0091
Daniil1945